Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an issue with the latest update of Google Chrome on my Xubuntu 14.04.

When I open a browser, it's webpage region is completely black, only toolbars are visible. When I try to resize or move browser's window it jumps to the bottom right corner of the screen and I can't get it out of there.

The screenshot:

Google Chrome window with black region

I've tried to re-install it, but it didn't help.

How do I fix it?


UPDATE #1

I've installed the latest version of chromium-browser just to see how it will perform.

There is no black screen in it, but I still have the problem of moving/resizing it's window.

share|improve this question
    
And what about lower versions? –  Mr.TK May 21 at 10:01
    
@Mr.TK you mean to install previous version? I'm not sure how to do this properly. I've installed Chrome from official Google's deb-package. –  Slava Fomin II May 21 at 13:18

2 Answers 2

Try disabling GPU compositing on all pages from the setting available on chrome://flags/ and see if it works. Hope this helps!

share|improve this answer
    
Thank you for your suggestion! Is there another way to change this flags? I can't change them from inside the browser itself for obvious reasons =) –  Slava Fomin II May 21 at 9:21
    
Did you try reinstalling chrome again? –  Ritik May 21 at 9:28
    
I just downloaded latest deb file from Google Chrome's website and re-installed it with GUI. Still no joy. –  Slava Fomin II May 21 at 9:31
2  
Click drop-down menu on top-right corner –> click “Settings” –> click “Show advanced settings…” on the bottom –> scroll to the bottom, and uncheck “Use hardware acceleration when available" Try using this –  Ritik May 21 at 9:35
1  
You can try disabling your plugins. –  Ritik May 21 at 9:40
up vote 1 down vote accepted

Looks like this problem was related to the Xinerama and proprietary NVIDIA drivers.

The black screen disappeared as soon as I switched to 304.117 version of NVIDIA drivers. Although, incorrect positioning of the window is still present, but I can coupe with this until better solution emerge.

I hope this will help someone.

share|improve this answer
    
Arch Wiki Xinerama "Warning: As of August 2013, Xinerama is broken when using the proprietary NVIDIA driver from 319 upwards. Users wishing to use Xinerama with the NVIDIA driver should use the NVIDIA 313 driver, which works only with Linux kernels earlier than 3.10." –  bain May 27 at 16:31
    
I have had precisely this problem. It remains unclear to me when (or if!) Xinerame (or the proprietary NVIDIA drivers) will be fixed. –  James S. May 28 at 13:35

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.