Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

I've managed to install Ubuntu 14.04 on my new Samsung ATIV Book 9 Lite ultrabook. After updating some configuratiosn in the UEFI installation was very easy. The only questions and issue I believe I'm still experience is when booting.

I believe when the laptop would be displaying the grub boot options I see the following. There is a black screen with a purple border of 10px around the screen. I'd like to know how I can update my system so that I see the grub boot manager.

I've run these commands:

sudo cat /etc/default/grub

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

The command was not possible, sudo efibootmgr.

share|improve this question

marked as duplicate by bain, Alaa Ali, Eliah Kagan, Eric Carvalho, Radu Rădeanu Aug 13 at 7:46

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
Can you edit the question with the output of sudo cat /etc/default/grub and sudo efibootmgr? –  ChrisR. May 20 at 21:59
    
Do I need to install efibootmgr with apt-get? –  mjwittering May 21 at 10:46
    
I would use the answer proposed by Subheer. The file that grub.cfg is generated from (/etc/default.grub) had the hidden timeout set. You only need efibootmgr if you have Ubuntu installed in UEFI mode. Considering efibootmgr is not present, you are most likely in BIOS mode. –  ChrisR. May 21 at 15:11

2 Answers 2

up vote 0 down vote accepted

I found the answer to my issue here, http://ubuntuforums.org/showthread.php?t=2226337.

share|improve this answer

Open terminal (ctrl+Alt+T) and run

sudo -H gedit /etc/default/grub

Edit the file put # before the GRUB_HIDDEN_TIMEOUT=0 and change:

GRUB_HIDDEN_TIMEOUT_QUIET=false

Save the file (not 'save as') and close it.

Now go back to terminal and run:

sudo update-grub

Now reboot and see.

share|improve this answer
    
I've tried do as you've suggested but it has solved my issue. Would installing efibootmgr help? –  mjwittering May 21 at 10:46
    
I get the following output when I run sudo update-grub after making the changes. Warning: Setting GRUB_TIMEOUT to a non-zero value when GRUB_HIDDEN_TIMEOUT is set is no longer supported. Found linux image: /boot/vmlinuz-3.13.0-24-generic Found initrd image: /boot/initrd.img-3.13.0-24-generic Found memtest86+ image: /boot/memtest86+.elf Found memtest86+ image: /boot/memtest86+.bin done –  mjwittering May 21 at 19:25
    
Try installing grub-customiser –  Sudheer May 22 at 6:58
    
What will grub-customiser let me do? –  mjwittering Jun 4 at 8:57
    
It will let you change the grub options –  Sudheer Jun 4 at 10:23

Not the answer you're looking for? Browse other questions tagged or ask your own question.