Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

1) I have maas server on Vm with 4 node all ubuntu 14.04 trusty 2) I have another VM as JUJU server i tried to bootstrap juju i got this error:

ERROR bootstrap failed: cannot upload bootstrap tools: Juju cannot bootstrap because no tools are available for your environment. You may want to use the 'tools-metadata-url' configuration setting to specify the tools location.

any suggestion?

share|improve this question
    
Rastin, great answer. I noticed in the web documentation that it shows: juju --sync-tools or juju bootstrap --sync-tools both of which don't work. –  Carl Aug 1 at 11:44

1 Answer 1

up vote 1 down vote accepted

The following two commands worked for me:

juju sync-tools --show-log 
juju bootstrap --debug
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.