Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After upgrading to Ubuntu 14.04 I can't connect to any new WPA2 wifi access points. Existing ones work.

Here is a pastebin of the syslog output: http://pastebin.com/QVgmRmXp

Here is an error that sometimes shows in a pop-up:

(nm-applet:28277): nm-applet-WARNING **: Connection activation failed: (1) Creating object for path '/org/freedesktop/NetworkManager/ActiveConnection/34' failed in libnm-glib.

There is a workaround, but it ain't pretty. When failing to connect, a file will be created here: /etc/NetworkManager/system-connections/<name of network> If I edit that file and add a password psk=password to the [802-11-wireless-security] section, then I can connect.

more info: http://pastebin.com/sLrq2s6M

share|improve this question
    
Please do what is in the accepted answer in the link below so we may see the information needed to help diagnose the issue. <askubuntu.com/questions/425155/…; –  Wild Man May 20 at 19:17
    
ps ax | grep wpa to check if /sbin/wpa_supplicant is running. –  Sneetsher Jun 20 at 22:02

2 Answers 2

Wireless drivers for ubuntu and linux are a little touchy when it comes to connecting to routers with certain settings, I am going to recommend the best settings to use.

I recommend that you change the encryption type in your router to WPA2 with AES (CCMP). Make sure not to select the WPA or WPA/WPA2 mixed mode, as that will again need TKIP which is discouraged.

Go into network manager and set your wireless settings to match the screenshots for best results. wireless settings1wireless settings2

Also do:

sudo ifconfig wlan0 down
sudo modprobe -rfv iwldvm
sudo modprobe -rfv iwlwifi
sudo modprobe -v iwlwifi 11n_disable=1
sudo ifconfig wlan0 up

this will be reset when you reboot but if it helps which it does in many cases we can make it permanent by:

echo "options iwlwifi 11n_disable=1" | sudo tee /etc/modprobe.d/iwlwifi.conf
sudo modprobe -rfv iwldvm
sudo modprobe -rfv iwlwifi
sudo modprobe -v iwlwifi

Reboot

share|improve this answer
    
This issue occurs with all password protected WPA* wifi access points, including ones that I do not control and it has nothing to do with DNS and IPv6 as far as I can tell, either, since it never connects. –  postfuturist May 20 at 21:07
    
You can install wicd then uninstall network manager and see if that fixes your issue but you must install wicd before removing network manger, I looked at the dmesg and it is pretty standard output, the things I suggested have been time tested. Wicd is better with encryption then network manager. –  Wild Man May 20 at 21:14

Follow these steps for changing to new WiFi network

  1. Click on WiFi Symbol which is beside the battery symbol.
  2. Click on Edit Connection which is at the bottom of the drop down.
  3. Select the network on which you want to connect, and then click edit button.
  4. Click on WiFi-security tab over there and enter the pass word of that network, save and close.

Now if you connect to this, everything will work fine.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.