Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I know this has been asked multiple times. I have tried multiple things, however nothing I seem to do stick. I am trying to disable the screen saver/screen blanking on Lubuntu 14.04. I've tried the following in rc.local, but nothing seems to actually disable it:

xset -dpms xset s off xset -dpms; xset s off

setterm -blank 0 -powerdown 0 echo -ne "\033[9;0]" >> /etc/issue

share|improve this question
1  
Tried method below, no luck! –  user3324834 May 27 '14 at 17:06

7 Answers 7

I had this problem on my Lubuntu system for ages too. I did 2 things to fix it:

  1. In lightlocker (Menu>Preferences>Lightlocker) make sure that 'blank screen' and 'switch off display after' are set to 'never'. Then make sure the 'Enable Lightlocker' switch is OFF.
  2. In XFCE Power Manager (Menu>Preferences>Power Manager) select the 'On AC' menu, then click the 'monitor' tab. Make sure 'Put display to sleep when computer is inactive for' and 'Switch off display when computer is inactive for' are both set to 'never'. Now do the same for the 'On Battery' menu.

Make sure you hit 'Apply' before closing each window, then reboot your computer and the problem should be fixed. It was for me anyway.

share|improve this answer
    
touching OnBattery settings helped me, lubuntu 14.10 –  shibormot Dec 21 '14 at 5:14

light-locker lies liberally. Even with it set to disabled, even with it explicitly telling me that locking was being handled by Xfce Power Manager, it still jumped in and locked the screen after resume from suspend.

Solution: sudo apt-get -y remove light-locker

And get on with your life.

share|improve this answer

In order to disable the scren blacking use the following two commands in the .xinitrc file before any existing exec startlxde command:

xset s off &
xset -dpms &

If you do not have this file please create it in your home directory and paste the above content:

touch ~/.xinitrc

Make sure it is an executable script, by running

chmod +x ~/.xinitrc
share|improve this answer
    
the first part was done before. I am trying the "chmod +x ~/.xinitrc" to see if that makes a difference. –  user3324834 May 27 '14 at 14:12
2  
Nope, didn't make a difference, still goes blank! –  user3324834 May 27 '14 at 17:06

managed to fix it by putting: "@xset s off" in my autostart file (after all other programs) and setting session idle timeout to its max value in dconf-editor (first install dconf-tools)

share|improve this answer
1  
Thanks for taking the time to answer the question. Would mind adding how to find the file and how to change the settings in the dconf-editor? –  MadMike Oct 17 '14 at 11:14

Add @xset s off in Start > Preferences > Default Applacations for LXSession > Autostart, where you see +Add type in the box next to it + Add Then click + Add

EDIT: Only works for a minute.

share|improve this answer

I have Ubuntu 14.04 installed with the Lubuntu desktop on a computer being used mainly for netflix (Netflix now works on chrome). In the middle of movies the screen would go blank and revert to lock screen when I pressed the spacebar.

  1. After some troubleshooting, I've determined I have the known and yet unfixed bug where the PowerManager will not run.

  2. I followed the directions above to deal with Lightlocker. The settings above had no effect. I determined I'm also having a second known bug where the settings in Lightlocker to disable screen locking are not working properly (see here https://bugs.launchpad.net/ubuntu/+source/light-locker/+bug/1287255). What worked for me was (Menu>Preferences>Lightlocker) flip switch to disable Lightlocker altogether.

share|improve this answer
    
If you have a new question, please ask it by clicking the Ask Question button. Include a link to this question if it helps provide context. –  Charles Green Nov 7 '14 at 16:54
1  
This does not really answer the question. If you have a different question, you can ask it by clicking Ask Question. You can also add a bounty to draw more attention to this question once you have enough reputation. –  kraxor Nov 7 '14 at 20:44

I know what's going on here. Problem is not how to set the screen saver (it's really easy and the light locker settings work just like they are supposed to work) - but that sometimes it keeps mysteriously resetting to its default position (10 minutes).

How? here's the punchline. Gnome Mplayer resets the screensaver for some reason on pause and exit.

Here's how to fix it:

  1. install VLC media player
  2. open preferences->default applications
  3. set default video player: VLC

and your screen saver will stay the way you want it to be.

share|improve this answer
    
Gnome Mplayer may or may not be resetting defaults, but I encountered the same issue as OP and my default video player has always been VLC. Disabling Lightlocker as mentioned in a different answer was effective on my machine. –  drkokandy Apr 22 at 20:57
    
@drkokandy: might be a different version then. I tested above behavior on Lubuntu 14.04. –  Hannes R. Apr 23 at 7:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.