Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've got a new laptop with an Nvidia GT750M graphics chip, and can't seem to get HDMI audio output working. An option for 'HDMI/DisplayPort' audio output is in my sound menu, but no test sounds will play through it.

The output of my aplay -l is:

kj@KJ-Laptop:~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: HDMI [HDA Intel HDMI], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: HDMI [HDA Intel HDMI], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: HDMI [HDA Intel HDMI], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: PCH [HDA Intel PCH], device 0: ALC668 Analog [ALC668 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

When I issue the following for the first time, I hear nothing

kj@KJ-Laptop:~$ aplay -D plughw:0,3 lel.wav

But if I run the command again, from there on after it works and the file is played through my HDMI attached speakers.

I therefore added the following line to my /etc/pulse/default.pa

load-module module-alsa-sink device=hw:0,3

This caused an additional device to appear in my sound options called 'Built-in Audio', but after selecting it the test sounds don't play and HDMI audio still doesn't work for other apps.

I get the feeling that this is close to working, since I can actually play stuff by manually specifying the device. Just looking for some help with the last step!

I have the proprietary driver installed, and configured to use the built-in Intel graphics rather than the discrete chip.

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.