Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I was very happy with my LXDE running on my Dell XPS 13 until, a few days ago, I found myself confronted with a dialgue box that presented the choices "desktop" or "laptop". It was set to "desktop", but I thought to myself "gosh, that cannot be correct" and so I set it to "laptop" and forgot about it.

A while later I began to experience problems with massive lag and slowdowns that I had never experienced before. I thought they were related to other issues but I have since discovered that plugging my laptop into external power seems to cure the problem instantly, and so I am coming to realise that I inadvertently messed something up.

The problem is that I do not remember where this dialogue box arose nor (exactly) what it was controlling. Can anybody indicate what I might have messed with and how to rectify it? I'm sure the dastardly setting was within one or two clicks of the LXDE main menu.

(Preferences > Power Manager would seem to be an obvious candidate but it tosses up dialogue box about Xfce4-power-manager not being loaded which I do not recall seeing when I messed things up, and even if I choose to load it I later get an error message about being unable to connect to it.)

share|improve this question
1  
Succeeded in getting Xfce4-power-manager-settings to run by invoking it from the command-line with sudo. It definitely isn't what I had messed with (I would remember it because it has a distinctive interface and has caused a new icon to appear in the system tray.) Incidentally altering settings here does not solve my problem either. –  qubex May 19 at 11:17
    
It turns out that the setting I remembered fiddling with was Preferences > Default applications for LXSession > Settings > Laptop mode. Changing it back from 'yes' to 'no' or (somewhat enigmatically) 'Unknown' does not seem to solve the issue. What does have an effect is starting and stopping TLP. –  qubex May 19 at 15:10

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.