Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

I have a computer running Ubuntu 14.04, with Windows 8.1 running inside VirtualBox. I needed Windows for a number of reasons, mainly for Office and OneDrive (school things).

My problem is that I can't seem to create a shared folder between the two computers. I have a folder /home/graham/Windows, that I have set as a shared folder for the guest in VirtualBox.

Edit: In regards to other documentation, most is for Windows has a host and Ubuntu as a guest, or an older version of Windows as a guest. Everything I find says the shared folder should just appear within Windows 8.1, but this is not the case.

When trying to mount \\vboxsvr\Windows within Windows 8.1, it says that the

server can't be accessed.

I have virtualbox guest addons installed on the guest.

Here is a screenshot of the error given by windows when trying to map the network drive:

Network Error

Any suggestions are greatly appreciated!

Graham

share|improve this question

marked as duplicate by Luis Alvarado May 20 at 2:21

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1 Answer 1

I normally go into Virtual Box setting for the VM in questions, select the folder to share and set the display name I want, and select permanent and auto-mount in the dialog box. Start the virtual machine and Windows should display your shared folders from the host OS as drive letters just like a mounted network share.

This only works if you have guest tools installed on guest OS.

Hope this helps.

share|improve this answer
    
I don't get an option for permanent in the dialogue box. I can specify the path of the folder, the display name, set it as read-only (which I don't), and set auto mount. I get the same error in windows as before. And I do have the guest tools installed. –  grahamhoyes May 19 at 2:00
    
@grahamhoyes can you add a screenshot of the error to your question –  TuKsn May 19 at 10:23
    
@grahamhoyes , you are logged in as graham/have read write permission for the folder your trying to mount right? –  user3623501 May 19 at 13:28
    
@Xubu-Tur I linked the screenshot on imgur, apparently I can't upload photos here yet. –  grahamhoyes May 20 at 2:09
    
@user3623501 I am logged in as graham on the host computer yes, and that account has read / write permissions for the folder. Do I need to specify them for the guest OS? And if so, how? –  grahamhoyes May 20 at 2:10

Not the answer you're looking for? Browse other questions tagged or ask your own question.