Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I want to upgrade the BIOS on an Intel main board using a program called iflash2.exe, provided by Intel, which runs only on MS-DOS. I do not have Windows operating system, and I am trying to create a bootable USB stick that will have MS-DOS compatible, iflash2.exe, and related files. I tried a program called UNetbootin, which created a bootable USB file with FREE DOS, but I do not know how and where to add the iflash2.exe and the related files. Can you tell me how I can do that?

share|improve this question
    
I'm not sure how to interpret your question: Do you have a bootable USB stick now? Or do you have an image file only, and you want to know how to put it on the USB stick? –  elmicha Jun 4 '11 at 14:20
    
@elmicha I have a bootable USB stick that has an image file on it. I want to know how to put additional execulatble files on the USB stick. –  sawa Jun 4 '11 at 22:04
    
When you plug the stick in, isn't it automatically opened, so you can drag and drop the files onto it? –  elmicha Jun 5 '11 at 7:12
    
@elmicha: A drive needs to be bootable in order to run any files at boot. @sawa: did you try actually writing the image to the drive rather than leaving the image file just sitting on the drive? As in actually extract the files in the image and write them to the disk? –  Thomas W. Jul 14 '11 at 11:57
add comment

2 Answers

I spent all morning struggling to find a way to flash the BIOS on my Zotac motherboard. Unetbootin creates MS-DOS images that will boot, but they cannot find the flash files (awdflash and N0422_ZA.bin in my case) on my USB thumb drive.

What finally worked was creating an Ultimate Boot CD and booting FREEDOS (not MS-DOS) from that CD. Then the USB thumb drive with my flashing files was visible, and the updating of the BIOS worked just fine.

share|improve this answer
add comment

STEP 1: BACKUP your data!!!

if your stick does not boot

Do you have wine? If not run in a shell sudo apt-get install wine -y

Then you should be able to open a terminal --not sure how that works, I don't have it installed nwo-- probably you would have to start cmd.exe in wine.

Then I would assume that the good old sys command will be available if the win terminal of wine provides you with sys.exe, then it suffices to type in that terminal sys c: d: (assuming here that the usb is d:)

Note that sys is probably an old command and will only work on all variants of FAT (I believe both disks have to be in FAT32). If that would not work, have a look here: http://www.winimage.com/bootpart.htm (I believe that running that in wine would solve your issue too).

if you have a bootable DOS stick (btw, to test if it works: set the USB as first bootable device in your bios, boot on it, then type dir<ENTER>: that should give you a list with files)

Then:

  • boot back in Linux
  • mount the usb-stick (dmesg to find its location, then sudo mount -o uid=$USER /dev/sdX /mnt/usb (where X is the letter found from the dmesg, /mnt/usb is a directory to be created using sudo)
  • cp iflash2.exe /mnt/usb (assuming that you're in the directory with iflash2.exe)
  • reboot
  • on the command line ---probably something like C:\>--- type iflash2<ENTER>
  • say a prayer and reboot ;-)

Ph.

PS: <ENTER> means that you have to press the ENTER button on your keyboard

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.