Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Can anyone please help me to solve the issue?

While updating update manager gives the following error:

The following packages have unmet dependencies:

**libqt4-declarative:** 
Depends: libqt4-network (= 4:4.8.1-0ubuntu4.8) but 4:4.8.1-0ubuntu4.8 is installed
Depends: libqt4-script (= 4:4.8.1-0ubuntu4.8) but 4:4.8.1-0ubuntu4.8 is installed
Depends: libqt4-sql (= 4:4.8.1-0ubuntu4.8) but 4:4.8.1-0ubuntu4.8 is installed
Depends: libqt4-xmlpatterns (= 4:4.8.1-0ubuntu4.8) but 4:4.8.1-0ubuntu4.8 is installed
Depends: libqtcore4 (= 4:4.8.1-0ubuntu4.8) but 4:4.8.1-0ubuntu4.8 is installed
Depends: libqtgui4 (= 4:4.8.1-0ubuntu4.8) but 4:4.8.1-0ubuntu4.8 is installed

**libqt4-declarative:i386:** 
Depends: libqt4-network (= 4:4.8.1-0ubuntu4.6) but 4:4.8.1-0ubuntu4.8 is installed
Depends: libqt4-script (= 4:4.8.1-0ubuntu4.6) but 4:4.8.1-0ubuntu4.8 is installed
Depends: libqt4-sql (= 4:4.8.1-0ubuntu4.6) but 4:4.8.1-0ubuntu4.8 is installed
Depends: libqt4-xmlpatterns (= 4:4.8.1-0ubuntu4.6) but 4:4.8.1-0ubuntu4.8 is installed
Depends: libqtcore4 (= 4:4.8.1-0ubuntu4.6) but 4:4.8.1-0ubuntu4.8 is installed
Depends: libqtgui4 (= 4:4.8.1-0ubuntu4.6) but 4:4.8.1-0ubuntu4.8 is installed

****libqt4-opengl:****
Depends: libgl1 but it is a virtual package
Depends: libqtcore4 (= 4:4.8.1-0ubuntu4.6) but 4:4.8.1-0ubuntu4.8 is installed
Depends: libqtgui4 (= 4:4.8.1-0ubuntu4.6) but 4:4.8.1-0ubuntu4.8 is installed

**libqt4-svg:** 
Depends: libqtcore4 (= 4:4.8.1-0ubuntu4.6) but 4:4.8.1-0ubuntu4.8 is installed
Depends: libqtgui4 (= 4:4.8.1-0ubuntu4.6) but 4:4.8.1-0ubuntu4.8 is installed

**libqtgui4:i386:** 
Depends: libqt4-declarative (= 4:4.8.1-0ubuntu4.8) but 4:4.8.1-0ubuntu4.8 is installed
Depends: libqtcore4 (= 4:4.8.1-0ubuntu4.8) but 4:4.8.1-0ubuntu4.8 is installed
share|improve this question

1 Answer 1

My guess is that you are missing one of the canonical repositories so will you please launch Software Sources and under Ubuntu Software tab make sure it is set similar to:

enter image description here

After changing setting make sure you run sudo apt-get update. You are then ready to retry the installation / update.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.