Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have ctrl-alt-backspace enabled to terminate Xorg in an xorg.conf.d file:

Section "InputClass"
        Identifier      "Keyboard Defaults"
        MatchIsKeyboard "yes"
        Option          "XkbOptions" "caps:super,terminate:ctrl_alt_bksp"
EndSection

This successfully kills the server and brings me back to the lightdm login screen. But after doing this I can't login anymore. After entering my credentials lightdm goes black for a second and then brings me back to the login screen.

I think the problem might be related to my encrypted home directory. After a reboot, if I login via a virtal console (ctrl-alt-F1) my home directory gets properly decrypted and mounted. If I stay logged in via the virtual console I can kill the X server and still login again in lightdm, presumably because my home directory didn't get unmounted (as I still had an active session open). But if I logout of the virtual console, killing the X server results in me not being able to login via lightdm and if I login using the virtual console my home directory doesn't get automatically unencrypted/mounted. According to the README that I see when my $HOME isn't mounted, I should be able to run ecryptfs-mount-private, but when I run that it exits immediately with an exit code of 0 and no error messages and it doesn't mount my home directory.

This is happening on Xubuntu 13.10.

I haven't found anything useful in any logs. Any tips on fixing this or diagnosing the problem would be appreciated.

share|improve this question
    
Sounds like your home directory is not getting unmounted. Do you see any errors in /var/log/auth.log? If you kill X, switch to a virtual terminal and login as root, and ls your home dir, is it still mounted? –  bain May 24 at 23:02
    
The home is not mounted, and doesn't get mounted automatically if I login from the virtual terminal. –  psanford May 25 at 0:19
    
Why the downvotes? –  psanford Jul 29 at 14:06

2 Answers 2

Press Ctrl +Alt +F1 . login there by username and password , then type sudo service lightdm restart

share|improve this answer
    
Restarting lightdm doesn't fix the problem. –  psanford May 28 at 12:39

I had a similar problem, my regular account was stuck in a login loop, but my guest account worked. The reason I couldn't login was because I had ssh'd into my computer and ran a sudo startx which changed the ownership of the .Xauthority file in my home directory to root.

A simple fix:

  • press [CTRL] + [ALT] + [F1] to get to text login.
  • run sudo mv .Xauthority .Xauthority_bak to disable the root owned .Xauthority
  • do a sudo reboot to restart.

It will create a new .Xauthority file owned by you and login should work as normal.

share|improve this answer
    
I don't have a root owned .Xauthority so this isn't my problem. –  psanford May 24 at 2:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.