Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently mounted the tmpfs in /dev/sda1 where the windows partition was supposed to be at so since then i got a invalid signature when i clicked the windows in grub menu. later I used boot-repair hoping it would solve it what it did was remove the windows from my grub choices. i've also tried reinstalling grub. i know i've got to change something with /etc/fstab but im too scared.

when i click os-prober i get no result, tried update-grub still nothing.

http://paste.ubuntu.com/7484895/ : is my Boot info script! Partition list are here

there's my partitions.

please help.. I just don't want any data to get deleted.

share|improve this question
add comment

2 Answers 2

You erased sda1 somewhere in the process. Usually sda1 with Windows installs is a hidden 100MB boot partition with the boot flag. It has essential boot files which are now missing from your system. You will need a Windows repairCD or flash drive and run repairs on you install in sda2. That will restore the missing bootmgr and /Boot/BCD files. Windows repairs the NTFS partition with the boot flag. You do not have to recreate sda1 unless you want to.

After fixing Windows run this in Ubuntu and it will then find the Windows install. os-prober looks for bootmgr & BCD to confirm that it is a Windows bootable partition. It does not use boot flag.

sudo update-grub
share|improve this answer
    
I did use the windows cd and opened a command prompt and typed bootrec /fixMbr /fixBcd /RebuildBcd but it says bootmgr not found ctrl+alt+del to restart. –  user282909 May 19 at 5:42
add comment

I accidentally formatted sda1, which was apparently my windows boot partition. At first I couldn't boot to windows or Ubuntu, so I made an efi boot partition and reinstalled Ubuntu on a spare partition. Now I can boot Ubuntu, but not windows. I will let you know if I figure it out. By the way, I have an Asus q500a.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.