Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to get my wusb300n card working on my desktop. I've downloaded ndiswrapper-1.59 and when I run make, everything goes fine except for a warning

WARNING: "mcount" [~/Downloads/ndiswrapper-1.59/driver/ndiswrapper.ko] undefined!

I am still able to make install it and it works. However, when I run

sudo modprobe ndiswrapper

I get

ERROR: could not insert 'ndiswrapper': Unknown symbol in module, or unknown parameter (see dmesg)

and dmesg gives

ndiswrapper: Unknown symbol mcount (err 0)

the same name from the make warning.

Some other info:

$ uname -r
3.11.0-20-generic

$ sudo modprobe -n -v --first-time ndiswrapper
insmod /lib/modules/3.11.0-20-generic/misc/ndiswrapper.ko

I'm on 64 bit Ubuntu 13.10

share|improve this question

1 Answer 1

After countless hours I've finally found the problem. It turns out I changed the version of gcc in order to install something a while back and that was causing the error. All I did to fix it was

cd /usr/bin
sudo rm gcc
sudo ln -s gcc-4.8 gcc

Remake everything, and then adding the ndiswrapper module worked!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.