Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I upgraded to 14.04 about a month ago on my HP Mini netbook (about 16 GB hard disk). A few days ago the system crashed (I don't know why but I was using internet at the time). When I restarted the computer, Ubuntu would not load. Instead, I got a message from the BIOS saying

Reboot and Select proper Boot device or Insert Boot Media in selected Boot device and press a key 

I took this to mean that I needed to reinstall 14.04.

When I try to reinstall Ubuntu from the USB stick, I choose "Erase disk and install Ubuntu" but then I get a message:

Some of the partitions you created are too small. Please make the following partitions at least this large:

/ 3.3 GB

If you do not go back to the partitioner and increase the size of these partitions, the installation may fail.

At first I hit Continue to see if it would install anyway, and it gave the message:

The attempt to mount a file system with type ext4 in SCSI1 (0,0,0), partition # 1 (sda) at / failed. You may resume partitioning from the partitioning menu.

The second time I hit Go Back, and it took me to the following partitioning table:

Device          Type      Mount Point    Format       Size      Used      System
/dev/sda
  /dev/sda1     ext4                     (checked)    3228 MB   Unknown
  /dev/sda5     swap                    (not checked) 1063 MB   Unknown

  + - Change                                       New Partition Table...     Revert

Device for boot loader installation:
/dev/sda ATA JM Loader 001 (4.3 GB)

At this point I'm not sure what to do. I've never partitioned my hard drive before and I don't want to screw things up. (I'm not particularly tech savvy.) Can you instruct me what I should do.

(P.S. I'm afraid the table might not appear as I typed it in.)

Results from fdisk:

ubuntu@ubuntu:~$ sudo fdisk -l

Disk /dev/sda: 4294 MB, 4294967296 bytes
255 heads, 63 sectors/track, 522 cylinders, total 8388608 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00000000

Disk /dev/sda doesn't contain a valid partition table

Disk /dev/sdb: 7860 MB, 7860125696 bytes
155 heads, 31 sectors/track, 3194 cylinders, total 15351808 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x0009a565

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   *        2768    15351807     7674520    b  W95 FAT32
ubuntu@ubuntu:~$ 

Here is what it displays when I open the Disks utility (I tried the screenshot terminal command you suggested but it didn't seem to do anything):

4.3 GB Hard Disk /dev/sda

Model: JM Loader 001 (01000001) Size: 4.3 GB (4,294,967,296 bytes) Serial Number: 01234123412341234 Assessment: SMART is not supported

Volumes Size: 4.3 GB (4,294,967,296 bytes) Device: /dev/sda Contents: Unknown

(There is a button in the utility that when you click it gives the following options: Format... Create Disk Image... Restore Disk Image... Benchmark

but SMART Data & Self-Tests... is dimmed out)

When I hit F9 Change Boot Device Order, it shows the hard drive as:

SATA:PM-JM Loader 001

When I hit F10 to get me into the BIOS Setup Utility, under Diagnostic it shows:

Primary Hard Disk Self Test Not Support

NetworkManager Tool

State: disconnected

Device: eth0 Type: Wired Driver: atl1c State: unavailable Default: no HW Address: 00:26:55:B0:7F:0C

Capabilities: Carrier Detect: yes

Wired Properties Carrier: off

When I run command lshw -C network, I get:

WARNING: you should run this program as super-user. *-network description: Network controller product: BCM4312 802.11b/g LP-PHY vendor: Broadcom Corporation physical id: 0 bus info: pci@0000:01:00.0 version: 01 width: 64 bits clock: 33MHz capabilities: bus_master cap_list configuration: driver=b43-pci-bridge latency=0 resources: irq:16 memory:feafc000-feafffff

*-network description: Ethernet interface product: AR8132 Fast Ethernet vendor: Qualcomm Atheros physical id: 0 bus info: pci@0000:02:00.0 logical name: eth0 version: c0 serial: 00:26:55:b0:7f:0c capacity: 100Mbit/s width: 64 bits clock: 33MHz capabilities: bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd autonegotiation configuration: autonegotiation=on broadcast=yes driver=atl1c driverversion=1.0.1.1-NAPI latency=0 link=no multicast=yes port=twisted pair resources: irq:43 memory:febc0000-febfffff ioport:ec80(size=128)

WARNING: output may be incomplete or inaccurate, you should run this program as super-user.

Additional Drivers

Broadcom Corporation: U98Z049.00 Wireless Mini PCIe Card

This device is not working.

[radio button not checked] Using Broadcom 802.11 Linux STA wireless driver source from bcmwl-kernel-source (proprietary)

[radio button checked] Do not use the device

share|improve this question
    
post the screenshot of your gparted partition editor. –  Avinash Raj May 18 at 23:34
    
The table above is the only partition editor I have encountered (which is accurately presented above). I just went there again and the only difference from last time was that now the line for "/dev/sda1 ext4" has a "/" under the Mount Point heading instead of being blank. –  Chris M. May 19 at 3:15
    
Sorry my fault the command should be sudo fdisk -l at the end its an l and not the number 1. More info fdisk –  TuKsn May 19 at 7:51
1  
@ChrisM. Please put new information into your question, not into comments. It is hard to read and probably will be overlooked by others. –  Dubu May 19 at 17:04
1  
From you information, I guess that /dev/sda is not the netbook disk but your USB stick (4 GB vs. 16 GB). Could that be? –  Dubu May 19 at 17:06

1 Answer 1

It looks like the USB stick you are using does not recognize the internal storage device (16GB hard disk, you say? It is probably an SSD or flash storage device.) The output from your commands are showing the USB device, not your internal storage device.

On a different computer, I would recreate the USB stick using the official 14.04 .iso file. For windows,PenDriveLinux.com has utilities that will help.

If you are on linux, it's easy enough to do as root.

  1. Format the USB stick using Fat32 (vfat) using Disks utility, fdisk&mfs, etc.
  2. Umount the USB stick
  3. Write the .iso file contents to the USB drive (note: do not "copy" the file), execute

# dd if=*ubuntu_file.iso* of=*path_to_usb*

Put the USB stick in your netbook, boot up, and when prompted select TRY UBUNTU (not install). This environment should help you troubleshoot and identify your harddisk.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.