Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've recently installed Ubuntu 11.04, which I'm unfamiliar with. I think the language package is installed correctly but there is no layout switching by using alt+shift combination. Tried to look for a solution. Have not found any instructions that work. Please help

share|improve this question
    
If the problem is solved, please accept an answer. –  con-f-use Jun 4 '11 at 10:27
    
Or if, as seems to be the case here that no answer was the solution, add that solution as an answer. –  misterben Jun 4 '11 at 10:37

1 Answer 1

I'm not sure if that is what you want. But if you want to change your keyboard layout using Alt+Shift then you could go about it this way:

Shortcut to switch keyboard layout

Go to "Keyboard Preferences" either using the keyboard indicator or dash. Than select the "Layout" pane. There click "Options" which will open the "Keyboard Layout Options". Under "Key(s) to change layout" you can check the box next to your desired shortcut.

I think this is outdated, but maybe worth a tray:

# In /etc/X11/xorg.conf

Section "InputDevice"
    Identifier      "Keyboard"
    Option          "XkbModel"      "pc105"
    Option          "XkbLayout"     "us,de" # de stand for german, replace this with your layout!
    Option          "XkbOptions"    "grp:alt_shift_toggle,lv3:ralt_switch"
EndSection

Edit: As stated in the comments: I didn't have a Greek keyboard layout in his layout list and had to add it like this:

enter image description here

share|improve this answer
    
Thanks, already did that, didn't work. Perhaps there's a problem with my language installation? Do I have to log out in order to take effect? –  Aleksandros Delarge Jun 4 '11 at 9:54
    
That's very odd. And no, typically it should work without restart. You could try dpkg-reconfigure locales and dpkg-reconfigure console-data also I edited my answer a litte. –  con-f-use Jun 4 '11 at 10:04
    
problem solved! I just have read more carefully ubuntu help documentation instructions, just had to ADD a greek layout for my keyboard. Sorry for wasting your time :( And Thanks of course :) –  Aleksandros Delarge Jun 4 '11 at 10:08

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.