Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently tried to replace Windows with Ubuntu 14.04 on an SSD. Somehow after installation I could not boot into the system. It said:

ERROR 1962 - NO OPERATING SYSTEM FOUND - PLEASE PRESS ANY KEY TO REPEAT BOOT SEQUENCE

Since my machine (A Lenovo ThinkCenter K410) uses UEFI, I used a EFI boot partition for EFI bootloaders, used the SSD for the system, and the original HDD as the data drive. What's weird is that it doesn't boot right after installation, but it boots after I use boot-repair to fix it. But when it restarts, it fails to boot and gives me the error code as above.

I did somehow run into a post regarding this problem and it indicated it was a Lenovo bug.

ERROR CODE 1962 - NO OPERATING SYSTEM FOUND - Lenovo Community

But here is my Boot-repair log:

Ubuntu pastebin

It said:

 => Grub2 (v1.99-2.00) is installed in the MBR of /dev/sdb and looks at sector 
17672192 of the same hard drive for core.img, but core.img can not be 
found at this location.

So is that the problem instead of the Lenovo bug? If so, how should I fix this?

Thanks!

share|improve this question

closed as off-topic by psusi, Fabby, Eric Carvalho, RPi Awesomeness, waltinator Jun 25 at 3:26

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This describes a problem that can't be reproduced that seemingly went away on its own or was only relevant to a very specific period of time. It's off-topic as it's unlikely to help future readers." – psusi, Fabby, Eric Carvalho, RPi Awesomeness, waltinator
If this question can be reworded to fit the rules in the help center, please edit the question.

3 Answers 3

On UEFI Hardware you have to install Ubuntu in UEFI Mode.

So When you boot on your installation drive you should see a black screen with grub to launch the live session :

UEFI Mode

And not the :

Not UEFI Mode

Try with to boot from your bios on your usb drive with uefi.

To check if your are in the right mode in the live session you can try :

[ -d /sys/firmware/efi ] && echo "Mode EFI" || echo "Mode classic"

Before installing Ubuntu I recommend to go to gparted to re-create the partitions needed for UEFI.

You might need to allocate at the beginning of your drive a partition for the bios (something like 5mo). And directly after you should have an efi partition who look like : Size : between 100Mo and 250Mo; Type : FAT32; Other : Flag "boot".

Now you can install Ubuntu via the graphical install and Ubuntu should detect the efi partition and install at the end the grub efi version.

I hope this solve your problems.

share|improve this answer
    
Yes, I tried to install it in EFI mode and yes it boots for the first time, but fails whenever after. And it boots every time right after I fix it with boot repair but not if I reboot again. It is weird I know. –  Kevin Hu May 18 '14 at 16:46
    
Could you check if grub is installed on your internal drive or on your usb drive ? –  Romain Fluttaz May 19 '14 at 21:57

You can also go into the BIOS and disable UEFI boot and select Legacy Boot instead.

share|improve this answer
    
The only BIOS-mode boot loader on the disk is on /dev/sdb, and it's clearly broken at the moment. Fixing that should be possible, but would require more effort. It will also require careful attention to the boot mode (BIOS vs. EFI). To be sure, this approach has merit, but it requires a much more detailed answer than you've provided. –  Rod Smith Jun 21 at 0:54

The Lenovo forum thread to which you link clearly indicates that the problem is (or at least can be) caused by a faulty cable. Thus, my first suggestion is to follow the advice in that thread and replace the cable, or at least re-seat it. This WikiHow article describes how to replace a SATA hard disk. Just replacing the cable is a subset of that procedure. You can try YouTube, too; I'm sure there are videos on it showing the process.

Beyond that, your setup is a bit weird. You have remnants of an old BIOS-mode GRUB installation on /dev/sdb; but these remnants probably indicate an installation to a GPT disk, given where the code points on the disk, and /dev/sdb is currently partitioned using MBR, not GPT. Your /dev/sdb1 is FAT and holds EFI boot loader files, which means it could be an EFI System Partition (ESP); but it's got the wrong type code for that, and Ubuntu won't normally install to an MBR disk in EFI mode. Your /dev/sda is a GPT disk, but it has no ESP. My hunch is that this mix of GPT and MBR disks allowed the Ubuntu installer to "slip through the cracks" and set up something that's almost right. Some EFIs may have problems booting from MBR disks -- this feature is not well-tested; it should work, but I'd be shocked if at least some EFIs don't have problems with it. Thus, you may have a "perfect storm" of unusual conditions that's causing you problems.

To correct it, you could try this:

  1. Back up your important personal data.
  2. Using gdisk, convert /dev/sdb from MBR to GPT, as described in the gdisk documentation. (I'm the author of gdisk, which is installed by default on Ubuntu.)
  3. Using gdisk, change the type code of /dev/sdb1 to EF00; or using parted or GParted, add a "boot flag" to the partition.
  4. Type sudo efibootmgr -c -d /dev/sdb -p 1 -l \\EFI\\ubuntu\\shimx64.efi -L ubuntu. (Note the double backslashes to separate directories in the -l option.) This should create a new boot entry that will stand a better chance of "sticking" across reboots, since it will now point to a GPT disk.

Note that any partition table changes are potentially risky. The MBR-to-GPT feature in gdisk is actually surprisingly simple, but it's conceivable that something will go wrong, hence step #1. Don't ignore it.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.