Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to install Steam on Ubuntu 14.04 but I'm missing a library

You are missing the following 32-bit libraries, and Steam may not run:

I have installed libgl1-mesa-glx:i386 but it still doesn't work Using the nvidia card with bumblebee (optirun) it starts normally, thus I don't know what this could be.

I have also Ubuntu 13.04 and I can start steam with the intel card without any problems, and use optirun only when launching the games

share|improve this question
Run in a terminal locate and see if you have it. Then you can make a symbolic link. – Cornelius May 17 '14 at 17:28
Thanks. It's strange that Steam doesn't locate the library. Anyway, I solved it with sudo ln -s /usr/lib/i386-linux-gnu/mesa/ /usr/lib/ :) Thank you – David Winchester May 17 '14 at 17:38
@DavidWinchester this sudo ln -s /usr/lib/i386-linux-gnu/mesa/ /usr/lib/ worked me too. thanks for posting the question. – zulucoda Jun 26 '14 at 19:59
up vote 10 down vote accepted

For the optimus-based ssytems, you need generic mesa libraries for normal operation, and then bumblebee will switch to the NVidia's ones when needed.

These links are actually controlled by the alternatives mechanism.
To choose which one you would like to use invoke:

$ sudo update-alternatives --config i386-linux-gnu_gl_conf
There are 3 choices for the alternative i386-linux-gnu_gl_conf (providing /etc/

  Selection    Path                                              Priority   Status
  0            /usr/lib/nvidia-331-updates/         8604      auto mode
* 1            /usr/lib/i386-linux-gnu/mesa/            500       manual mode
  2            /usr/lib/nvidia-331-updates-prime/   8603      manual mode
  3            /usr/lib/nvidia-331-updates/         8604      manual mode

Press enter to keep the current choice[*], or type selection number: 

Be sure to set up the mesa one.

Same for the 64bit libraries:

$ sudo update-alternatives --config x86_64-linux-gnu_gl_conf
There are 3 choices for the alternative x86_64-linux-gnu_gl_conf (providing /etc/

  Selection    Path                                          Priority   Status
  0            /usr/lib/nvidia-331-updates/         8604      auto mode
  1            /usr/lib/nvidia-331-updates-prime/   8603      manual mode
  2            /usr/lib/nvidia-331-updates/         8604      manual mode
* 3            /usr/lib/x86_64-linux-gnu/mesa/      500       manual mode

Press enter to keep the current choice[*], or type selection number:

Reboot the system afterwards and try launching steam again.

share|improve this answer
This is what I do, but there's no need to reboot. Just run sudo ldconfig instead and see if it worked. – Bruno Nova Oct 18 '14 at 9:39
Cyryl + Bruno method worked for me – mdesantis Mar 18 '15 at 21:58

@DavidWinchester running this command (below) works well:

sudo ln -s /usr/lib/i386-linux-gnu/mesa/ /usr/lib/ 

thanks for posting the question

share|improve this answer
It is really not necessary to create any links with sudo in /usr. (Really, almost never). Use the update-alternatives answer. – Peter Smit Feb 17 '15 at 7:12

I had the same issue, every time I tried to run steam it would tell me the error. All I did was type this into terminal and open steam back up and it worked.

sudo apt-get install libgl1-mesa-glx-lts-utopic:i386

If this works for you, please upvote. Also, if you experience more issues, let me know in the replies. I will be happy to help

share|improve this answer

Your solution is in the webpage above. Uninstall all current nvidia drivers you have and install those ones.

share|improve this answer

protected by Community Aug 24 '15 at 2:52

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.