Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have 12.04LTS on a Dell Inspiron laptop, and it behaves very strangely when I plug my Samsung Galaxy SII phone into it.

When I connect the phone, I get three dialog boxes, one says "Unable to mount SAMSUNG_Androit...Error initializing Camera: -60 could not lock device" Then the other two are the typical "You have just inserted a digital audio player..." asking what to do (there are two I think because there are effectively two SD cards in the phone, one "built-in" and one plugged into it.

Anyway, if I ask one of the dialogs to go to the files, I see two devices with the little eject icons beside them, a bunch of folders, and a couple of files. However, if I try to look inside anything, it appears empty (not true, in case it needs saying!)

Also, if I run the mount command, that doesn't show the device(s) anywhere, and if I use the command line to do "cd /media ; ls -a" the media location is empty.

If I plug the same phone, with the same cable, onto another machine running Ubuntu 13.10, it works just fine. One device shows up, with two subfolders, and those folders (representing the two SD cards in the phone) all contain their regular data. It also shows up under mount and ls /media in the way I would expect.

Oh, one more thing. A regular memory stick works fine in that socket.

Any suggestions?

TIA, Simon

share|improve this question
    
I'm noticing the same behavior this morning. My Galaxy Nexus always auto mounted on 12.04 until this morning. I only connect it occasionally. On my laptop with 14.04 the phone connected as expected. –  Antonios May 17 at 16:56

1 Answer 1

Mount it manually.

01) Identify the device using lsblk command:

enter image description here

I'll assume it's sdc1

02) Then issue the mount command:

sudo mount /dev/sdc1 /mnt

03) Browse your files:

nautilus /mnt

share|improve this answer
    
The phone does not show up on the output of lsblk. lsusb shows Bus 005 Device 003: ID 04e8:6860 Samsung Electronics Co., Ltd GT-I9100 Phone [Galaxy S II] –  Antonios May 17 at 19:35
    
OP's phone also does not show up with lsblk. ls -l /dev/sd* shows several partitions of sda and an unidentified sdb, but although sdb is reported as a block device, if I try dd -if /dev/sdb | od -x | less, it shows it as zero length. And, as if it were even worth testing, it does not mount... –  Simon May 18 at 2:46
    
OP also, on Antonio's indirect suggestion, tried booting the machine from a 13.10 disk I had lying around, and that boot sees the device properly, and can browse it in Nautilus. I'll probably upgrade it to 14.04 and keep my fingers crossed. –  Simon May 18 at 2:58

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.