Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I've just updated my laptop to Xubuntu 14.04, and after the update my keyboard has changed to English-English(US). This is OK for most keys, but it swaps @ with ", and loses the pound sign (The English currency one - not #).

If I go to settings manager > hardware > keyboard, I can change the keyboard to English(UK), but this seems to have no effect.

A new icon appears on the top bar, and this appears now control keyboard layout. Googling has led me to the ibus command and this seems to control this new system. However, the only gb english settings I get from ibus list-engine are:

xkb:gb:dvorak:eng - English (UK, Dvorak)
xkb:gb:extd:eng - English (UK, extended WinKeys)

The dvorak one completely messes up my alphanumeric keys, the later has the same problems as the US layout.

How do I get back to a bog standard English UK keyboard layout

share|improve this question

2 Answers 2

I have an answer that works for me. I have just found this post: https://bugs.launchpad.net/ubuntu/+source/ibus/+bug/1284635

That suggests to me ibus is problematic, so I uninstalled it:

sudo apt-get remove ibus

Then rebooted and everything is back to normal and working properly.

share|improve this answer
    
Very odd bug - and odd, too, that it hasn't been definitively squashed yet. I just experienced it this morning on a vanilla Ubuntu 14.04 setup. I ran the software updater, but can't see which package would be responsible for messing with this ibus/keyboard setting. I hadn't had any trouble before this morning. As I say - odd! I got back to normal using the ibus-setup workaround as detailed in that bug-report you helpfully linked to. Thanks! –  Davïd May 20 '14 at 7:40
    
Setting the keyboard to English (UK, extended WinKeys) didn't work for me - though it may have been that I didn't delete the English(US) entry. –  user1014251 May 20 '14 at 9:24

This happened to me after a recent update. To resolve it I went to system settings -> language support ->keyboard input method = none. Logged out and in and it's back to a UK keyboard.

share|improve this answer

protected by Community Feb 25 at 18:24

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.