Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

If I enter a command, the output is translated in the language I am using on the system. But if I use sudo to run a command with root privileges, the output is always in English. How can I change this?

share|improve this question

1 Answer 1

up vote 0 down vote accepted

You can't.

But there is a workaround:

  • If you haven't already done so, go to System Settings -> Language Support and click the "Apply System-Wide" button.
  • Get root privileges using sudo su

Reference: https://help.ubuntu.com/community/EnvironmentVariables#sudo_caveat

share|improve this answer
    
Thank you. I will try to set it in /etc/sudoers. –  EliasEx May 17 at 6:03
    
@EliasEx: Sounds dangerous. Nothing I would try. –  Gunnar Hjalmarsson May 17 at 19:04
    
How can I change the global local variable in the console? I need this for a server with out an UI. –  EliasEx May 17 at 19:12
    
@EliasEx: /etc/default/locale is intended for setting the locale globally. –  Gunnar Hjalmarsson May 18 at 2:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.