Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'd like to remove a keyboard icon, so replacing "[###] USA" as keyboard layout indicator to just "En", an English or American flag, or "USA" at least. How can I achieve this?

UPDATE: When I've clicked to remove e-mail icon from the bar, keyboard language indication has disappeared also, and now I only see that useless keyboard icon, and don't see what language is selected now :-(

I use Ubuntu 10.10.

share|improve this question
add comment

5 Answers

up vote 8 down vote accepted

In addition to monotasker's solution, here's exact steps how to easily get flags instead of keyboard icon + abbreviation:

  1. in gconf-editor, check /desktop/gnome/peripherals/keyboard/indicator/showFlags
  2. install set of flags using sudo apt-get install famfamfam-flag-png
  3. make a softlink: ln -s /usr/share/flags/countries/16x11 ~/.icons/flags

In the next login, you should see flags in indicator applet.

share|improve this answer
    
I am experiencing the same problem, but the given answer is not exactly the answer of the question. Yes, the solution works for the INDICATOR applet, but what we would like to have is a solution for the NOTIFICATION area. For some reason now the keyboard indicator there can't find the icons, other than the default crappy keyboard picture. In addition I use the connected application 'Typing Monitor', which also doesn't show icon in the NOTIFICATION bar. I am not sure if they are going to fix it officially bugs.launchpad.net/ubuntu/+source/gnome-settings-daemon/+bug/… –  user11408 Feb 24 '11 at 14:02
add comment

The solution here is to turn on the "show flags" option and install some flag image files.

I've posted a pack of SVG language flags (along with instructions for installing and enabling them) here (for dark panels) and here (for light panels).

The light-panel version looks best with Faenza or Elementary iconsets, but is also not bad with ubuntu-mono-light. The dark panel version is really best suited for Faenza. If there's enough interest, I can create another set to match ubuntu-mono-dark. The gnome-look.org pages include instructions for installing the sets.

And if I've missed your language, let me know the code and I'll add it to the set.

share|improve this answer
add comment

[Solved]

To completely remove the keyboard indicator we need to change one byte in the /usr/lib/gnome-settings-daemon-2.0/libkeyboard.so file.

  1. Make a backup of libkeyboard.so file.
  2. Open the file with root privileges through any hex editor (I use Bless).
  3. Search for the byte signature FF 83 F8 01 0F

    FF 83 F8 01 0F = if (g_slist_length (current_kbd_config.layouts_variants) > 1)

  4. Change 01 to 02

    FF 83 F8 02 0F

  5. Save the file. (this should be the new contents of the file)

    FF 83 F8 02 0F = if (g_slist_length (current_kbd_config.layouts_variants) > 2)

If you have less than 3 keyboard layouts, icon will be not shown. After this, you need to reload gnome-settings-daemon, you can use reboot for this.

share|improve this answer
1  
worked perfectly for me. Even though i have version 3 (gnome-settings-daemon-3.0/libkeyboard.so) and the sequence is found twice. I changed both of them –  disjunction Oct 14 '13 at 14:44
add comment

I think icon will be removed from indicator in release. So just wait 2 weeks. See https://bugs.launchpad.net/ayatana-ubuntu/+bug/620331 for further information. And note "Fix commited" status of that bug.

EDIT: Try /apps/gnome_settings_daemon/plugins/keyboard/active=false for now. Also, install xneur (auto-layout switcher for X).

share|improve this answer
add comment

This is a tutorial on how to change the keyboard layout indicator so it displays country flags:

http://elementaryos.org/docs/user-guide/customizing/language-layout-flags

share|improve this answer
1  
While this link may answer the question, it is better to include the essential parts of the answer here and provide the link for reference. Thank you. –  Peachy Aug 26 '12 at 15:39
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.