Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am having problems enabling bluetooth since installing xUbuntu 14.04 on my Thinkpad X220, in 13.10 all was working fine.

When I installed 14.04 I did a fresh install rather than upgrade.



returns no such file or directory, so I'm guessing that I don't have the appropriate IBM bluetooth drivers installed.

/proc/acpi/ibm/ only contains: beep, cmos, driver, fan, hotkey, led, light, video, volume

Where can I get these from?

Cheers Jim


It would appear that the Bluetooth daughter card is not being recognised at all, I have swapped the card over as I have 2 of them, but still no luck. As far as I am aware the Bluetooth daughter cards are USB based.

The output of 'lsusb' returns:

Bus 002 Device 003: ID 15ca:00c3 Textech International Ltd. Mini Optical Mouse
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 004: ID 04f2:b217 Chicony Electronics Co., Ltd Lenovo Integrated Camera (0.3MP)
Bus 001 Device 003: ID 147e:2016 Upek Biometric Touchchip/Touchstrip Fingerprint Sensor
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
share|improve this question
Addition: As expected Fn + F5 won't enable Bluetooth either, but it does switch WiFi on and off. – James Valentine May 16 '14 at 16:15
What will happen if you run sudo service bluetooth restart – TuKsn May 16 '14 at 16:39
@Xubu-Tur When I run that command it returns: Bluetooth Stop/Waiting Bluetooth Start/Running Process 5254 But still no Bluetooth even after Fn+F5 or running blueman-manager Cheers Jim – James Valentine May 16 '14 at 16:43
Perhaps this link can help – TuKsn May 16 '14 at 17:02
@Xubu-Tur, thank you for that link, I believe that is one of the ones I was reading the other day. I have just gone through the list of answers attempting each one in turn, restarting the bluetooth service after each one. Unfortunately still no joy though. Cheers Jim – James Valentine May 16 '14 at 17:14

Have you tried ThinkWiki bluetooth setup guide? I got my ThinkPad bluetooth working thanks to this:

I am not sure if this works for you but its worth a shot.

share|improve this answer
What worked for me: sudo su; echo 1 > /sys/devices/platform/thinkpad_acpi/bluetooth_enable After a quick restart all was well again. – indivisible Oct 20 '14 at 16:46

Install Bluetooth drivers and necessary packages:

sudo apt-get install bluez bluez-alsa bluez-audio bluez-btsco bluez-compat bluez-cups bluez-dbg bluez-gstreamer bluez-hcidump bluez-pcmcia-support bluez-tools bluez-utils python-bluez bluewho indicator-bluetooth libbluetooth-dev  libgnome-bluetooth11 libbluetooth3 python-gobject python-dbus

Then try to connect via the application bluez.

share|improve this answer

I had the same problem, thinking that was the OS version, but no. It was hardware. So I just got a spare Bluetooth Daughter Card Module:

You can get it from ebay:

To install it, unscrew the screws at the base of the laptop with a keyboard icon, then, lift-up the keyboard, next remove the plastic cover where your wrist rest while typing, trackpad, etc included. Below lays the Bluetooth Daughter Card Module, nearby where the Thinkpad logo is. Replace it. Repair done.

Here you can see some pictures of where the module it is actually installed in a X220 laptop:

share|improve this answer
Off topic? Ja klar, – Matías Jan 9 at 7:44

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.