Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a Macbook Pro 5,5 running Ubuntu 11.04 Natty amd64. It performs like a dream, but in ubuntu (both 10.04, 10.10 and 11.04), I have had problems getting the correct keyboard layout.

My Macbook Pro is with a danish keyboard, and almost all the keys does fit the symbols. But there are some keys that don't.

E.g., if I wanna type $, I gotta press Alt+4, where on OS X, I can just press on the $ key. If I do, however, press the $ key, it gives me a ½. Also @ is a bit off. In OS X, to type @, I would press Alt+[the @ key], but in Ubuntu, it will type ˝ (only with double-press on keys, single press wont do anything), and to type @, I will actually have to press Alt+2.

I have set my keyboard layout to Danish Macintosh keyboard (with and without dead keys) and tried all such things, but it doesn't fix it.

How do I get a proper keyboard layout that matches the symbols on my keys?

share|improve this question

closed as too localized by jrg, Marco Ceppi Dec 3 '11 at 23:41

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
This question appears to be abandoned - if you feel this is in error, then please flag as such explaining why and the moderators will reopen it. :) –  jrg Dec 3 '11 at 23:05

1 Answer 1

In keyboard Preferences > Layouts > Keyboard model try to set vendor to Apple and pick proper keyboard model.

share|improve this answer
    
Thanks for the suggestion. I picked Apple as vendor and Macbook/Macbook Pro (intl) as model, as that is what I have. It did give a different result in the "preview" and such, but it didn't fix the problem. It does sound like it could be one of the maybe many steps to take for it to function properly. –  chrisbuchholz Jun 3 '11 at 18:55
    
Hm. If you picked right keyboard model and keyboard layout it should work. If they put your keyboard model on the list it should be supported. You can consider filling in a bug report if you don't manage to make it work. –  umpirsky Jun 3 '11 at 21:08

Not the answer you're looking for? Browse other questions tagged or ask your own question.