Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

How do I switch the keyboard layout in Ubuntu 11 so that the Apple key is Ctrl and the ~ works correct?

This is the specific keyboard I'm talking about:

enter image description here

When I hit Shift-2 it returns a "

share|improve this question
Do you also have errors when you try to type '@'? – boehj Jun 3 '11 at 13:06
Yep, Shift+2 = " – Tom Jun 3 '11 at 13:28
You already tried to change the layout under System -> Preferences -> Keyboard? – Bobby Jun 3 '11 at 21:13

There are two ways you can accomplish this task: The first way it GUI based, using:

Open Applications > System Tools > Configuration Editor
Then apps > metacity > global_keybindings in the tree view

This should enable you to modify your key values as long as you stay within the acceptable syntax.

The alternate way to edit your keybindings is by directly editing the gconf.xml files:


You can find more information at

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.