Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am totally new regarding Ubuntu, recently converted from Windows. A friend installed Ubuntu 13.10 on my laptop a few months ago. It's been working great up until about thirty minutes ago.

I booted up the system tonight after having shut it down this morning before work. Upon startup my mouse/cursor is missing, my internet connection is disabled (despite the wireless adapter being switched on and the internet connection working fine on other devices in the house). I am able to use the keyboard and access the terminal, but I don't know the first thing about fixing this issue.

I tried searching the Ubuntu forums and Ask Ubuntu, but I don't see any issues that mimic mine. I also, unfortunately, am unable to offer any sort of system data because I can't access the internet or use the mouse on my laptop to even obtain such data.

I really need help. I can't even begin to speculate how this happened considering everything was working fine at 8 a.m. this morning.

share|improve this question
    
Thank you to everyone for attempting to help. The problem is fixed. I found that wired connexions were a no go. But a USB mouse allowed me to use my mouse. I attempted updates (not thinking that I wasn't connected to the internet). Not sure if they took, but I rebooted again to attempt another solution I found on here, and when my laptop booted up again everything was fine. Consider this closed - although not ~technically~ solved. –  Necrohazard May 16 at 14:01
add comment

3 Answers 3

To try to resolve the missing cursor issue, you can take a look at this post.

To reenable the internet connection you can try entering the following command in the terminal:

sudo rfkill unblock wifi

share|improve this answer
    
I did try the cursor fix that you linked to no avail. I will try the internet fix though. –  Necrohazard May 16 at 2:57
add comment

I sometimes have similar issue with the cursor. Touchpad gets disabled sometimes. Did you check that. In my laptop, Fn+F3 key combination toggles touchpad on and off. There's a wifi on/off key combination too, which is Fn+F2 in my laptop.

share|improve this answer
    
These were two of the first things I did - no dice. Thanks though. –  Necrohazard May 16 at 13:59
add comment

I had the same problem and I found out what happened, I had to stop apt-get while installing wine, and ever since that happened everything started, anyways I just purged wine (you'll maybe need to purge some other pckg) from the terminal using aptitude and everything came back to normal try doing the same ;)

Oh and to solve the pointer problem so it's easier to fix this try this command:

sudo modprobe psmouse
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.