Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Well, i recently installed Ubuntu 14.04 in a HDD of 640 GB capacity. After the installation, I decided that i should partition my HDD so to have on the one partition the os and some other files (320 gb) and save to the other partition my video-edit works (320 gb). And I did so using the Ubuntu 14.04 live cd and gparted. I formatted the new disk part "with" ext4. But then something wird happened: While i am using ubuntu without any problem, i cannot edit the second partition, which means that i can't save or create something there! Ubuntu says that I am not the owner!! Why?? I need to solve this immediately!

EDIT: Both of these two solutions below worked for me! However, faster way proved to be the one I have chosen!

share|improve this question
    
Is your partition automatically mounted somewhere? What does mount says about mounted partitions? If you can mount it, what's who's the owner of the mount point? –  Sergey P. aka azure May 15 at 16:13

2 Answers 2

up vote 0 down vote accepted

Type

 mount 

in terminal and find the partition which you want to change ownership

my output looks like enter image description here

if I want to change ownership of partition /dev/sd8 which is a ext4 partition and mounted on /media/bibi/films

you can also check ownership of mounted partitions with command

 ll /media/bibi

as you can see my films folder is owned by root

enter image description here

To change the ownership I have to run

sudo chown -R bibi:bibi /media/bibi/film

enter image description here

you have to substitute bibi with your user name

It is explained here http://ubuntuforums.org/showthread.php?t=1137537

share|improve this answer
    
Thank you very much! I am new to Ubuntu, so I didn't know that! :D –  user258486 May 15 at 16:33
    
if it solved your problem you can accept the answer :) –  Bibi424 May 15 at 16:37

Because the partition was created outside your Ubuntu installation, it is owned by some other user, probably the super-user of the live cd. You can either reformat the partition inside Ubuntu and assign it to the current user or simply change read/write permissions so that the current user has access to that partition. This might also require giving the current user permissions to mount that partition.

share|improve this answer
    
Thank you!!! :D –  user258486 May 15 at 16:34

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.