Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have lots of HDD's on my system, all but one are on USB. Here's my output from ls -la /dev/disk/by-id/:

ata-INTEL_SSDSC2CW060A3_CVCV2041010Y060AGN -> ../../sdc
ata-INTEL_SSDSC2CW060A3_CVCV2041010Y060AGN-part1 -> ../../sdc1
ata-INTEL_SSDSC2CW060A3_CVCV2041010Y060AGN-part9 -> ../../sdc9
ata-M4-CT032M4SSD3_0000000013180377C645 -> ../../sda
ata-M4-CT032M4SSD3_0000000013180377C645-part1 -> ../../sda1
ata-M4-CT032M4SSD3_0000000013180377C645-part2 -> ../../sda2
ata-M4-CT032M4SSD3_0000000013180377C645-part3 -> ../../sda3
ata-M4-CT032M4SSD3_0000000013180377C645-part4 -> ../../sda4
ata-ST1000LM010-9YH146_Z2M0110M -> ../../sdb
ata-ST1000LM010-9YH146_Z2M0110M-part1 -> ../../sdb1
ata-WDC_WD30EZRX-00MMMB0_WD-WMAWZ0282248 -> ../../sdg
ata-WDC_WD30EZRX-00MMMB0_WD-WMAWZ0282248-part9 -> ../../sdf9
usb-WDC_WD30_EZRX-00D8PB0_000000000000-0:0 -> ../../sdd
usb-WDC_WD30_EZRX-00D8PB0_000000000000-0:0-part1 -> ../../sdd1
usb-WDC_WD30_EZRX-00D8PB0_000000000000-0:0-part9 -> ../../sdd9
usb-WDC_WD30_EZRX-00D8PB0_000000000000-0:1 -> ../../sde
usb-WDC_WD30_EZRX-00D8PB0_000000000000-0:1-part1 -> ../../sde1
usb-WDC_WD30_EZRX-00D8PB0_000000000000-0:1-part9 -> ../../sde9

as you can see, most of the drives look to be correct, but the part9 of ata-WDC_WD30EZRX-00MMMB0_WD-WMAWZ0282248 is pointing to a different drive (sdg for parent, sdf9 for part9).

Why does this happen? This is screwing up my ZFS. Ubuntu server 13.10.

I didn't edit udev rules aside from preventing the wwn-* symlinks from appearing.

share|improve this question
    
Also see: serverfault.com/questions/596712/… –  ewwhite May 17 at 16:20
    
Did this occur after a reboot? A system update? –  ewwhite May 17 at 18:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.