Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Whenever I reboot my system (ubuntu 14.04 with gnome 3.12) all the gnome shell extensions turn off. I can just re-enable them and they work fine until I reboot again. What can I do to make gnome restart the same shell extensions on startup?

share|improve this question
add comment

1 Answer 1

GNOME 3.12 isn't available by default in Ubuntu repositories for 14.04. You must have installed GNOME 3.12 from the Staging PPA of the GNOME Team. They warn that:

The packages here have been deemed not ready for general use, they have known bugs and/or regressions, sometimes of a critical nature. Mostly things should run smoothly but be prepared to use ppa-purge, when you encounter issues!

So you should report a bug about it as mentioned on their Launchpad page.

However, the workaround that you may try is as follows:

  1. Enable all the extensions you wish to be enabled at boot.

  2. Then, run the following command:

    $ gsettings get org.gnome.shell enabled-extensions 
    

    This would list all the extensions that are enabled currently. For example, the output for me is:

    ['apps-menu@gnome-shell-extensions.gcampax.github.com', 'places-menu@gnome-shell-extensions.gcampax.github.com', 'window-list@gnome-shell-extensions.gcampax.github.com']
    
  3. Now, create a file called enable_gnome_extensions.sh inside ~/bin folder with the following text in it:

    gsettings set org.gnome.shell enabled-extensions "<output_of_earlier_command_listing_enabled_extensions>"
    

    For example, I would put the following line for my enabled extensions:

    gsettings set org.gnome.shell enabled-extensions "['apps-menu@gnome-shell-extensions.gcampax.github.com', 'places-menu@gnome-shell-extensions.gcampax.github.com', 'window-list@gnome-shell-extensions.gcampax.github.com']"
    
  4. Make this file executable with the following command:

    $ chmod +x ~/bin/enable_gnome_extensions.sh
    
  5. Add this file to your Startup Applications for it to be executed at login. Follow this answer for how to do it. The "command" would be the path to that file.

Reboot to test if it works.

share|improve this answer
    
I don't think it could work --- /etc/rc.local is run well before the user login and the graphic environment is up. I have the same problem with gnome 3.10, and I use exactly this solution but I have it in a script in my ~/bin that I add to the startup scripts. –  Rmano May 14 at 17:00
    
@Rmano Thanks for your input. I just tested it using /etc/rc.local and it didn't work. I have made necessary modifications now. Thanks once again :-) –  Aditya May 14 at 18:22
    
In a fresh Ubuntu Gnome 14.04 updated to Gnome 3.12 today, I could not access startup applications in an easy way. This work-around worked: linuxandfriends.com/how-to-add-startup-programs-in-gnome-3 –  Rasmus Jun 13 at 0:52
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.