Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have two videocards Integrated(Intel i3) and Discrete(Mobility Radeon HD5470).

I noticed this problem, after I installed Catalyst 11.5 from AMD site. But there was something I couldn't manage, external monitor worked only in mirror mode with fglrx, and had to revert to open drivers. I removed fglrx with

Had some problems with booting to Ubuntu, but i successfully managed to start it. Unity works, some games like OpenArena, in low-medium configuration works almost perfect. I assume that open driver is working.

I reenabled vgaswitcheroo, and turned off radeon (because of overheating problems). But when i try glxgears, it shows me Segmentation Fault.

dmesg shows:

glxgears[10065]: segfault at 502 ip 00007f486ea4c6d5 sp 00007fffca5567e8 error 4 in[7f486ea1c000+21d000]

What can I do now?

PS I think if I install fglrx again, segfault will disappear (IMHO, didn't tested), but external monitor won't work as I need

share|improve this question
up vote 0 down vote accepted

After updates from xorg-edgers (didn't noticed when exactly) the problem solved itself

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.