Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have installed Xubuntu 14.04 and now when I switch on the laptop's bluetooth hardware switch, I don't see the Bluetooth icon in the notification area nor in the indicator plugin (as used to happen with 13.10 and earlier). I made sure that the "bluetooth" and "blueman" packages are both installed, than I tried starting blueman-assistant from the commandline and I got a message box saying "No adapters found".

What should I do to make blueman recognize the adapter?

I am on a 64bit version of 14.04 and using a HP Compaq610 laptop.

Cheers.

share|improve this question

2 Answers 2

First some good news... There seems to be a simple workaround to restore the highquality A2DP interworking to your Bluetooth headset.

1) Use Blueman to pair to the headset. My experience was that it will pair and even connect as headset with the horrible audio quality "Telephony Duplex (HSP/HFP)" audio profile.

2) The Ubuntu Sound Control panel wont however show the Bluetooth device yet!

3) Open a command terminal and issue the command: pulseaudio -k

4) After a short delay you should see the Headset appear in the listed audio devices of the Ubuntu Sound Control Panel

5) Select the device and connect some audio source (VLC Media or your favourite player)... The quality will still be poor...

6) Now use Blueman GUI, select the device and press mouse right click and then select the "Refresh Services". It should show a succes message in the lower status bar.

7) Right click on the headset device in Blueman GUI and select Audio Sink. If it displays a success message your in luck.

8) Now right click the headset device in Blueman GUI and select Audio Profile menu and then select "High Fidelity Playback (A2DP)". It should suceed and switch into the correct mode.

==> You will always have to issue the "pulseaudio -k" command from terminal before using the headset, but it's a tolerable work around.

Hope this works for you too.

share|improve this answer
    
Killing pulseaudio seems counter-intuitive. Perhaps this is a bug in pulseaudio? –  Elder Geek May 24 at 14:57
1  
@elder I just use this command: gksudo pactl load-module module-bluetooth-discover instead of killing it. Would this work instead? –  Tim May 25 at 8:35
    
@Tim if it worked for you, put it in the Answer box so that it can help others. –  Elder Geek May 25 at 13:12
    
i appreciate the effort but what are you talking about? I never mentioned a Bluetooth headset. this answer doesn't relate to my question... –  Lawand May 25 at 23:15

Install bluetooth common drivers for ubuntu.

Then try to connect through Bluez.

 sudo apt-get install bluez bluez-alsa bluez-audio bluez-btsco bluez-compat bluez-cups bluez-dbg bluez-gstreamer bluez-hcidump bluez-pcmcia-support bluez-tools bluez-utils python-bluez bluewho indicator-bluetooth libbluetooth-dev  libgnome-bluetooth11 libbluetooth3 python-gobject python-dbus
share|improve this answer
    
I tried that but I still get the "No adapters found" error... –  Lawand May 25 at 23:13

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.