Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

the bluetooth is disabled on my Ubuntu (Dell vostro Desktop with bluetooth USB adapter).

I plugged the bluetooth USB adapter to another Ubuntu desktop (12.04) and it is recognized instantaneously.

I've tried a bunch of different solutions that I found on online forums, but I couldn’t fix that.

I've installed blueman, bluez, bluetooth support package.

The bluetooth system settings shows the message "bluetooth is disabled" even after I turn it on. Bluetooth status is not shown in the menu bar even though I checked this option.

"rfkill list" says bluetooth isn't blocked.

"lsusb" says the dongle is connected.

bluetooth manager doesn't work... all buttons are grey.

Removing gnome-bluetooth (as some users suggest) not only doesn't fix the problem but also removes ubuntu-desktop, causing my system settings be missing among other consequences.

Bluetooth option is not shown in the BIOS. Do I need t install a drive maybe? Does it exist?

All I want is to be able to connect my Apple mouse and keyboard to the PC.

Please help.

share|improve this question
I have not, but I just did. How can I use it to try to solve the issue? – aguiar May 13 '14 at 20:00
Sometimes the usb device may not identified as a bluetooth device mode. in such occations usb-modeswithch helps. but it works after restarts the computer. – user224082 May 13 '14 at 20:04
I restarted the computer. It doesn't help. – aguiar May 13 '14 at 20:08
So, try with installing all the applications need for bluetooth devices by sudo apt-get --reinstall install bluez bluez-alsa bluez-audio bluez-btsco bluez-compat bluez-cups bluez-dbg bluez-gstreamer bluez-hcidump bluez-pcmcia-support bluez-tools bluez-utils python-bluez bluewho indicator-bluetooth libbluetooth-dev libgnome-bluetooth11 libbluetooth3 python-gobject python-dbus – user224082 May 13 '14 at 20:13
I installed everything and restarted the computer. Still doesn't work. Sorry. – aguiar May 13 '14 at 20:22

Try this:

sudo hciconfig hci0 reset
share|improve this answer
Can't init device hci0: No such device (19) even though it most certainly does exist. hci0: Type: BR/EDR Bus: USB – Redsandro Feb 11 '15 at 15:31
worked for me.... Thanks... :) – Ashwani Kumar Rahul Mar 1 at 6:53

This solved the problem for me.

Terminal output for

rfkill list
0: hci0: Bluetooth
Soft blocked: no
Hard blocked: no
1: asus-wlan: Wireless LAN
    Soft blocked: no
    Hard blocked: no
2: asus-bluetooth: Bluetooth
    Soft blocked: no
    Hard blocked: no
3: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no

After reading several other posts, I found this solution. Install gksu if not already installed.

sudo apt-get install gksu -y

Then edit /etc/rc.local and enter this line just before the "exit=0" entry.

gksudo gedit /etc/rc.local

In gedit before the last entry, which is "exit=0", enter:

rfkill unblock bluetooth

Then reboot and you should be able to turn on bluetooth, if not already enabled after reboot.

share|improve this answer
Thanks! This worked for me. rfkill unblock bluetooth – Kervin Ramen Jun 29 '15 at 6:55

I just found a workaround for my Lenovo T400 running 14.04.2 LTS.


  • Bluetooth was working
  • I turned it off in settings panel.
  • Now, when I try to turn it on, It turns itself off again.
  • check 'rfkill list' and see that bluetooth is soft blocked.
  • type 'sudo rfkill unblock bluetooth'
  • check 'rfkill list' and see that bluetooth is still soft blocked.


  • Use the hardware switch on the front of the laptop to turn off the radios and then turn them back on.
  • notice in control panel that bluetooth is now on.

You may have Fn-F8 or some such keyboard combination which may work for you.

This may not be the best solution but it gets me out of a bind for now.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.