Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using a Lenovo Ideapad laptop with graphics card configuration as Radeon HD 8570A/8570M on Ubuntu 14.04. It shows me "The System is running in low graphics mode" while booting. So i am following this answer to solve my error.

I have tried amd-catalyst 14.4 and 13.12 from this site. But while installing these drivers, my terminal goes like this:

enter image description here

When I click or close the message box, the installation stops. So how do i install the appropriate driver?

share|improve this question
    
Have you already tried to use fglrx from the Ubuntu repos? It should be as simple as running sudo apt-get install fgrlx or if you want a newer version sudo apt-get install fglrx-updates. Before running these commands, make sure to have the "restricted" repository enabled (see help.ubuntu.com/community/Repositories/Ubuntu ). –  soulsource May 13 at 15:24
    
If you insist on installing the drivers from the AMD website, do not install them directly, but make distribution specific packages instead and install those. By this you will be able to uninstall the driver easily if you need to. The command should (I'm guessing) be: ./amd-gpu.run --buildpkg Ubuntu/trusty. Maybe ./amd-gpu.run --help might be worth a look. Installation of .deb files might make troubles with Software Center, but should work with gdebi or using the command line. –  soulsource May 13 at 15:28
    
@soulsource, i tries intalling fgrlx first. But after i install it, and log in , nothing happens. The screen remains blank with no icons or topbar or sidebar like this askubuntu.com/questions/17381/… So i uninstalled fglrx and did this askubuntu.com/questions/283985/… –  Diffy May 14 at 9:44
    
It might sometimes be necessary to run sudo aticonfig --initial after installing fglrx. This will detect your screen setup and prepare an /etc/X11/xorg.conf file. If you already have such a file, the current version will be backed up to /etc/X11/xorg.conf.original-0. Nevertheless, if you uninstall fglrx, make sure to put back the backup file of xorg.conf (or, if you didn't have an xorg.conf before running aticonfig, you should delete the xorg.conf file when uninstalling fglrx). –  soulsource May 14 at 10:33
    
i installed fglrx again and also did sudo aticonfig --initial. But nothing comes after login screen. –  Diffy May 14 at 13:57

2 Answers 2

This is because you are running the installer as a normal user. Try to run it with: sudo ./amd-gpu.run

share|improve this answer
    
I will try this. –  Diffy May 14 at 9:34
    
So, did worked? –  Frantique May 14 at 10:42
    
Still the pop up boxes are coming as blank. THere are some other message boxes coming but with blank buttons and no text at all –  Diffy May 14 at 13:43
    
BTW, i somehow install it and i get the message "Installation complete", but still the problem persist. –  Diffy May 14 at 14:50

I tried this on my lenovo, it works.

http://ubuntuforums.org/showthread.php?t=2216720

ganda@Lenovo-G400:~$ /usr/lib/nux/unity_support_test -p
ATTENTION: default value of option vblank_mode overridden by environment.
ATTENTION: default value of option vblank_mode overridden by environment.
OpenGL vendor string:   Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) Sandybridge Mobile x86/MMX/SSE2
OpenGL version string:  3.0 Mesa 10.1.0

Not software rendered:    yes
Not blacklisted:          yes
GLX fbconfig:             yes
GLX texture from pixmap:  yes
GL npot or rect textures: yes
GL vertex program:        yes
GL fragment program:      yes
GL vertex buffer object:  yes
GL framebuffer object:    yes
GL version is 1.4+:       yes

Unity 3D supported: yes

share|improve this answer
    
thanks @qanda for the help.My laptop was struck in the tty mode and it was crashing regularly.So i switched to windows. –  Diffy Jun 1 at 5:33

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.