Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a USB drive (SanDisk SDCZ40-016G) that mounts in a way I've never seen before. When inserted, two items appear in Places -> Computer:

Computer

"SanDisk Ultra Backup: 16GB" contains my data, and "CD Drive: U3 System" contains a Windows executable. The part with the Windows executable doesn't look useful to me so I'd like to remove it. I used GParted to delete the only partition listed on the device and then I created and formatted a new partition:

GParted

Strangely, the "CD Drive" containing the Windows executable was perfectly intact after this operation.

What's going on?

share|improve this question
1  
I just hate that –  Pitto Jul 11 '11 at 16:49

7 Answers 7

up vote 18 down vote accepted

The solution came from u3_tool (universe), which can:

  • uninstall the U3 software
  • reclaim the CD-ROM disk space
  • run on Ubuntu

I ran sudo u3-tool -p 0 /dev/sdb and then repartitioned the drive. Now it mounts like a "normal" USB drive.

share|improve this answer
1  
OMG, it's possible to replace the virtual CD image??? I was thinking it was hardcoded in a ROM! What they were smoking at SanDisk?? In this way someone could place a virus and it would be ran on Windows with the autorun.inf!!! Crazy –  Magnetic_dud Jan 4 at 18:21

U3 is proprietary software that SanDisk loads on it's USB drive. It runs in a partition you can't reformat, or really detect, and it'll likely always be there.

If you have a Windows machine you can run the Un-installer using the guide in the SanDisk KB. There is also supposedly an uninstaller application at the U3 website but I can't get the site to load for me currently

share|improve this answer

U3 Uninstaller is windows only. Available here:

http://www.softpedia.com/get/Tweak/Uninstallers/U3-Launchpad-Removal-Tool.shtml

I know of no way to do this in Linux.

share|improve this answer
    
I have one of those disks too. The U3 uninstaller previously mentioned worked for me. However, I see no reason to get those drives anymore. It is just too bad that the actual space for the CDROM cannot be recovered as usual disk space. –  jfmessier Sep 24 '10 at 12:10

Okay, here's a way to remove it on Ubuntu. First if you don't have it, do to Ubuntu Software Centre and download the 'Wine Windows Program Loader' after the download go to: http://www.geekyjock.com/pages/blog/2006/05/remove-u3-software-from-your-usb-flash.html And download the removal software for U3 at the end of the blog. Run the removal software with Wine and you're good to go!

share|improve this answer

I ran into a similar problem, was unable to delete a small U3 partition on my sans disk cruzer USB pen drive. I tried doing so within windows disk utility and used diskpart from the run prompt. the following didnt work for me, the u3 partition which appeared as a CD on my computer could not be deleted: SD formatter 4 did not work either: http://www.pendrivelinux.com/restoring-your-usb-key-partition/

U3 tool wouldn't run for me at all on windows 7

and

the one at sourceforge

had luck through sans disk website: http://kb.sandisk.com/app/answers/detail/a_id/2550/~/removing%2Funinstalling-u3-launchpad-on-a-pc#method2

which can also be found on instructables

share|improve this answer

In Linux (for me) it appears as another disk. You might be able to format that part. Personally I will not recommend it in the odd case it stops up the device, but I doubt it would.

share|improve this answer

You can't, unless the drive contains software to tell it to stop doing that (and that software would probably be Windows only).

It is the drive itself that identifies itself as two units on the USB-bus instead of just one. One being the actual disk, and the other a CD-ROM with the U3 software.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.