Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I disabled the lock in the "Brightness & Lock" but I still get the lock screen when is resumes/wake from suspend. Although the option "Require my password when waking from suspend" is unchecked

share|improve this question
up vote 18 down vote accepted

There is two steps involved into completely disabling the lock screen in Unity.

  1. Go to Brightness & Lock panel from the Unity Launcher. And set Turn screen off when inactive: to Never
  2. Install "Unity Tweak Tool" with sudo apt-get install unity-tweak-tool. Run it from the Launcher and select System > Security > Enhance system security by disabling Desktop lock
share|improve this answer
    
You can accept your own answer. – kzh Oct 3 '14 at 16:28

go to search , type Unity, in the options displayed find and double click on option "Unity Tweak Tool", a windows opens inside that you will find main options like

Unity

Windows Manager

Appearance

System

under "system" there are 3 sub option "Desktop" , "Security", "Scrolling"

  • click on security, under security tab do a check on option "Desktop Lock"

I am adding this solution just in case if unable to find the option.

Thanks for the all previous post's. very helpful and informative.

share|improve this answer

None of these worked for me, but I found some info in this bug report.

As a result of what I read in the bug I ended up doing this:

sudo mv /etc/xdg/autostart/light-locker.desktop /etc/xdg/autostart/light-locker.desktop.bak

That seemed to do the trick.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.