Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently upgraded my server from 12.04 LTS to 14.04 LTS.

Mostly everything went well. However one thing isn't working for me and I'm trying to figure out what I missed.

I re-visited the settings and confirmed they were set to what I had before the upgrade, but now when SpamAssassin tries to update at night my cron job emails me this:

/etc/cron.daily/spamassassin:
gpg: WARNING: unsafe ownership on homedir `/var/lib/spamassassin/sa-update-keys'
gpg: failed to create temporary file `/var/lib/spamassassin/sa-update-keys/.#lk0x16728d0.mail.nomorestars.com.13916': Permission denied
gpg: keyblock resource `/var/lib/spamassassin/sa-update-keys/secring.gpg': general error
gpg: failed to create temporary file `/var/lib/spamassassin/sa-update-keys/.#lk0x16728d0.mail.nomorestars.com.13916': Permission denied
gpg: keyblock resource `/var/lib/spamassassin/sa-update-keys/pubring.gpg': general error
gpg: no writable keyring found: eof
gpg: error reading `/usr/share/spamassassin/sa-update-pubkey.txt': general error
gpg: import from `/usr/share/spamassassin/sa-update-pubkey.txt' failed: general error
gpg: process '/usr/bin/gpg --homedir='/var/lib/spamassassin/sa-update-keys' --batch --no-tty --status-fd=1 -q --logger-fd=1 --import' finished: exit 2

I've checked and the user account settings and permissions appear correct. Any suggestions on where I can look? I'm sure it's something that was changed permission by the upgrade I just can't seem to locate it.

share|improve this question

1 Answer 1

up vote 0 down vote accepted

have you tried this link: http://krischan.eu/index.php/2014/04/21/spamassassin-bug-gpg-validation-failed/

Looks like they had a similar problem and ended up re-importing the GPG key.

Mike

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.