Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just upgraded to 13.10 this weekend (I know 14.04 is out, I'm not doing that yet) and have lost my login. There used to be two user accounts I could choose to log in from on the startup page, mine and the dummy one created by a coworker when he was helping me with something. After the upgrade, the only user account I could log in to belongs to my coworker. My account data is still there (I can access it when I log in as him and cd to /home/username) but I don't know how to log in as my old user account. It also doesn't show up in the user accounts Settings view. How do I add it back?

Note: I tried using the answer to this question: Why are my user accounts missing from login screen after upgrade to 14.04 from 12.04 ? and got the response "user 'username' already exists"

share|improve this question
    
sudo userdel username and then useradd? –  M132 May 12 at 18:35
    
won't that delete the account and related files? I just want a way to be able to log in. –  norabora May 12 at 18:44
    
It shouldn't unless you add --remove flag. See userdel --help. –  M132 May 12 at 18:45

3 Answers 3

I had to edit /etc/lightdm/lightdm.conf as root and add:

greeter-hide-users=false
greeter-show-manual-login=true
allow-guest=false

When I go to the startup screen, I am now able to type in my username and log in.

share|improve this answer

You could try to install lightdm again enter from the terminal:

   sudo apt-get install --reinstall lightdm

it should work fine that way.

share|improve this answer

I have had the same problem you could also try to enter in the terminal:

    sudo apt-get autoremove gdm
    sudo apt-get autoremove lightdm

and then in the terminal enter:

    sudo apt-get update
    sudo apt-get install lightdm
    sudo apt-get install gdm

and then in the terminal enter:

    sudo -f --dismiss-Option::="unity-greeter-gtk" install --reinstall unity-greeter

and then reconfigure the unity-greeter enter in the terminal:

    sudo apt-get --reconfigure unity-greeter

and this could maybe also work fine this way.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.