Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Recently I have begun experimenting with Lookit, a screen capture upload application. At this point I have not tried the upload capabilities. That is, my various screen captures are simply being saved locally.

When the screen capture is saved, a PNG is being created and, when viewed from Nautilus, an accurate thumbnail is displayed. However, when I attempt to view the file in an application such as the Image Viewer in Ubuntu, nothing is displayed. Additionally, when I tried to upload the file, photobucket.com choked. The Shotwell Photo Viewer also would not display the PNG. I did find that GIMP would display the image and could subsequently be edited.

What is the difference between the PNG produced by Lookit and PNGs produced by other applications? Is there a fix that allows the Lookit PNG to be viewed by all standard viewers?

share|improve this question
    
I had similar problems with import in former times - today they seem to be gone. The pictures had an offset, so that there was a transparent image of the real size, but the content was somehow outside of the visible area. I wrote a script, which used ImageMagick to heal the image, but today import is working fine for me. If you're interested, I can share the script. –  user unknown Jun 2 '11 at 0:20
    
I would be interested in taking a look at the script you put together. –  Kory Wnuk Jun 2 '11 at 1:32
    
Lookit from the Lookit PPA (not the Lookit Testing PPA) works fine here. Update: the version from the testing PPA also doesn't show the symptoms you describe. –  htorque Jun 2 '11 at 8:01
add comment

1 Answer 1

up vote 1 down vote accepted

As explained in the comments, I had a similar problem, which I handled with a script, which I show here, in the hope it could help:

#!/bin/bash
#
# autocrop an image, shot by 'import', where an imageoffset is (why, oh, why?) 
# allways annoyingly produced 
#
f=$1 || exit 1 
img=$(identify $f) || exit 2
size=$(echo $img | cut -d ' ' -f3) || exit 3
offset=$(echo $img | sed 's/[^+]*+//;s/ .*//g') || exit 4
convert $f -crop $size+$offset +repage autocrop-$(basename $f) || exit 5

It produces a new file - from screenshot-1.png to autocrop-screenshot-1.png . Renaming the initial file to uncropped-screenshot-1.png would be more comfortable - a possible improvement.

share|improve this answer
    
The script works perfectly. Thanks. While not necessarily a fix for the issue, it certainly merits recognition. –  Kory Wnuk Jun 2 '11 at 23:17
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.