Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've tried to enable support for HTTPS as well as HTTP for my SVN service. Previously this worked over HTTP and worked well.

I'm using (stuck with): Ubuntu 8.04 SVN 1.5 Apache 2.2.8

I've created the certificate, default-ssl, 000-default-ssl I copied my trac_svn file as trac_svn_ssl and edited to be:

NameVirtualHost *:443
<VirtualHost *:443>

        ServerName vmserver:443

        DocumentRoot /var/www/
        <Directory />
                Options FollowSymLinks
                AllowOverride None
        </Directory>
        <Directory /var/www/>
                Options Indexes FollowSymLinks MultiViews
                AllowOverride None
                Order allow,deny
                allow from all
        </Directory>

        ErrorLog /var/log/apache2/error.log
        LogLevel warn
        CustomLog /var/log/apache2/access.log combined
        ServerSignature On

<Location /svn>

   DAV svn
   SVNParentPath /var/vmstorage/svn    
   AuthType Basic
   AuthName "Subversion Repository"
   AuthUserFile /var/vmstorage/svn/svnauth    
   Require valid-user
   AuthzSVNAccessFile /var/vmstorage/svn/svnaccess
   SSLRequireSSL
</Location>
...SNIP...

I can browse to http://vmserver and http://vmserver/svn I can browse to https://vmserver

But if I browse to https://vmserver/svn it just 404s

I don't even know what other files to post to help out.

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.