Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running Ubuntu 12.04 LTS. Upon updating clam definitions with sudo freshclam I got the message that my current clam software (0.98.1) was outdated and that I should upgrade to 0.98.3., which I tried to do in many steps (below) but was stopped by the error message "checking for OpenSSL installation/usr" and then "Configure error: OpenSSL not found"; even though SPM shows that OpenSSL IS installed v 1.01-4 ubuntu 5.13! Here is what I've tried so far:

  1. uninstalled clamav 0.98.1.
  2. downloaded clamav 0.98.3; unzipped that folder and then changed directory to that folder and ran in Terminal: ./configure. After a minute this process then stops at the above error message about 'OpenSSL not found".
  3. I've tried to install clamav 0.98.3 from Ubuntu Packages with sudo apt-get instal clamav clamav-daemon and clamav-freshclam.
  4. I've tried to install clamav 0.98.3 by first updating my system with sudo apt-get update and sudo apt-get upgrade, and then
  5. sudo add-apt-repository ppa: Ubuntu-clamav/ppa' and sudo apt-get upgrade again, and then sudo freshclam again to update the definitions; all to no avail.

I've since re-installed clamav 0.98.1 because I don't want to be without an anti-virus protection, even one with outdated definitions. But, I still want to update clamav to 0.98.3. Where did I go wrong and where to I go from here to successfully upgrade/install clamav 0.98.3? Thanksc

share|improve this question
1  
Is there any reason why you feel you need an antivirus scanner? Is this a server that is providing services to Windows clients or similar? If not, there really isn't much point in having one. Also, the message you are referring to was just a warning, there should be no reason you can't updated your definitions without updating the scan engine. Just ignore the warning and let sudo freshclam do its thing. –  terdon May 12 at 15:47
    
The only reason I'd prefer an antivirus scanner for Ubuntu is that I maintain multiple computers that are dual boots with Windows, but it's good to hear that the now outdated Clamav version 0.98,1 can be updated with freshclam and still remain effective. I guess I'll wait until a new package for Clamav 0.98.3 is available before upgrading. Maybe then I'll also learn why the "OpenSSL not found" error came up. Thanks for your guidance on this. –  user12809 May 13 at 13:57
    
The dual boot is irrelevant. If you share a partition between both OSs, just scan that from Windows. Its only an issue of course if it is a file system that Windows can read natively. –  terdon May 13 at 14:02
add comment

protected by Community May 15 at 20:11

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Browse other questions tagged or ask your own question.