Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I use a ASUS N550JV laptop (UEFI) and I tried to dual boot 64bit Ubuntu 14.04 on it, along side with Windows 8. I have two hard drives and /dev/sdb is a SSD so I want to install Ubuntu on it (Windows is also installed on this drive). But when the auto installation runs, it tries to install grub on /dev/sda, so it fails. So, I made 30GB unallocated space in Windows then used a USB drive with Ubuntu ISO in it. I partitioned the 30GB space as follows:

/boot 100MB   ext2 primary
/     8192MB  ext4 logical
/home 20480MB ext4 logical
swap  the rest of space (about 4GB)

and I chose /dev/sdb as location to install boot loader. The installation run without reporting any error. But when the installation completed and the system rebooted, grub does not appear in the boot options. I went into boot options in BIOS and check efi directory and did not find grub either. What shall I do with situation? Thanks in advance.

p.s. There actually exists two grub 1.99 in efi partition, which are left by unsuccessful installation of Ubuntu 13.10 and Debian 7.5. When I use them, there appears a grub command line, which I have no idea how to use. Is this causing the problems?

share|improve this question
    
Is secure boot off? What errors did you get when installing Debian 7.5? What errors are you getting now? . If you are running on UEFI then by default the boot loader (grub) will be in /efi /Debian /grub.efi for Debian installations anyway. Then you would need to install rEFInd boot manager to switch between OS's, it may not be quickest but it works well –  user67350 May 12 at 2:08
1  
If you solved your problem, please, answer your question and mark it as accepted. –  Danatela May 12 at 6:46
add comment

1 Answer 1

up vote 0 down vote accepted

There were two options when I boot: Sandisk and UEFI:Sandisk. Things does not work if I choose the one without UEFI. It will only work if I choose the one with UEFI.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.