Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My nVidia card was enabled and working fine, but then I tried to use nvidia-prime, but never got the PRIME settings in nvidia-settings. I found that there is a bug regarding this and decided to revert to my previous state.

For this, I uninstalled all nvidia stuff (apt-get purge nvidia-*), reinstalled nvidia-331 and went into my BIOS to use the nVidia card only (no optimus or anything).

Now it looks like nVidia is being used again, but I think this is not true. "About this computer" as well as "Additional Drivers" tell me that it is active and using the proprietary driver.

But if I, for example, start TMNF (Trackmania, a game) with Wine, it tells me it can't find the video card performance and when I start playing the game, it is very laggy and has graphics glitches – things that definitely weren't there before.

Another thing that makes me believe something is wrong: When booting, I get the grub screen asking what to boot and one screen asking me to unlock my hard drive. When using the Intel card, these screens had high resolution; using the nVidia card made them have poor resolution. In the current state, the first screen (grub) has poor resolution, but the unlock screen has high resolution as if it switched from nVidia to Intel during booting.

Lastly, when opening the nvidia-settings, I get very little information/options, which usually is the case when the Intel card is active.

Does anyone have any ideas what I could try or how to fix this? Reinstalling the system is something I'd really like to avoid.

Update: I tried several methods described here and all tell me the nouveau driver is being used, not the proprietary one. If I boot the kernel with nomodeset, I am stuck with super low resolution.

Edit: My setup: Lenovo T530 with Ubuntu 14.04.

share|improve this question
    
Well I think I just soft bricked myself. Can't boot, no matter which card I choose in the Bios. I'll look into it tomorrow but looks like I'll have to reinstall afterall... –  Ingo Bürk May 11 at 21:50

1 Answer 1

up vote 0 down vote accepted

As mentioned in the comment, I ultimatively ended up getting my laptop into a state where I couldn't boot it, no matter whether I set it to the Intel or nVidia card in the BIOS.

So I used a LiveCD to back up some data and went for a reinstall. However, the nVidia driver still didn't want to work. There were a few problems, some of which I figured out what went wrong, but never why it went wrong (this was a fresh install!)

  • the nvidia driver just wouldn't load, even if it was installed.
  • nividia-xconfig didn't exist (solution: it did, but for some reason the path wasn't set correctly, so it wasn't in the path).
  • the nouveau driver was loaded despite being blacklisted.
  • although the nvidia installation executed update-initramfs, I noticed changes in the boot behavior after doing it manually after the installation.

After figuring out the path problem and what not I got it to work, but since there were a few iterations of experiments, I decided to once again start over new and reinstalled Ubuntu once more, expecting to having to apply the path fixes etc.

But – and here comes the weird part – this time nvidia installed just fine. The path was correct and nvidia prime instantly worked out of the box.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.