Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have an Ubuntu server on Amazon EC2, that I use for development, and today I stupidly cleared everything out of my ~/.ssh/authorized_keys file. Luckily I have an SSH open, so I am still connected, and can fix the file, but when I try to put my key file back, it doesn't work. I still get permission denied from the server on my local machine.

authorized_keys has the permissions 600. I have tried appending my SSH key with ssh-rsa and leaving the ssh-rsa off. I also tried making the SSH key all one line, but that didn't work either.

Is there something else that I have to do like reload the file some how?

share|improve this question
Years later, this -still- seems relevant & active; only wanted to make an observation, talk about having had dodged a bullet: "Luckily I have an SSH open, so I am still connected [..]" - sheesh! ;dP – Nostromov Mar 15 at 2:23
up vote 106 down vote accepted

You should never save the file with its contents starting with -----BEGIN RSA PRIVATE KEY----- on the server, that is your private key. Instead, you must put the public key into the ~/.ssh/authorized_keys file.

This public key has the .pub extension when generated using ssh-keygen and its contents begin with ssh-rsa AAAAB3. (The binary format is described in the answers to this question).

The permissions of ~/.ssh on the server should be 700. The file ~/.ssh/authorized_keys (on the server) is supposed to have a mode of 600. The permissions of the (private) key on the client-side should be 600.

If the private key was not protected with a password, and you put it on the server, I recommend you to generate a new one:

ssh-keygen -t rsa

You can skip this if you're fully sure that nobody can recover the deleted private key from the server.

If this does not help, run ssh with options for more verbosity:

ssh -vvv

On the server side, you can review /var/log/auth.log for details.

share|improve this answer
With Amazon EC2 servers all I get is the private key (key.pem). I don't have a public key anywhere. – Dave Long Jun 1 '11 at 17:04
@Dave Long: You must generate a new key using ssh-keygen -t rsa and put the newly created file in ~/.ssh/authorized_keys on your server. See also… – Lekensteyn Jun 1 '11 at 17:33
@DaveLong: You can generate the public key from the private key at any time. You can do this simply with the following command: ssh-keygen -y -f key.pem > – Morgan Blackthorne May 17 '13 at 0:40
@MorganBlackthorne While that is true, I would recommend generating your private keys rather than accepting one from remote sources. You cannot be fully sure that the private key did not get leaked. – Lekensteyn May 17 '13 at 8:49
@Gerrat Fixed². – Lekensteyn May 31 '14 at 19:59

If you have login based authentication then use ssh-copy-id to append your public keys to remote server.

ssh-copy-id user@host
share|improve this answer
That doesn't seem to be a valid command on Mac, which is what my client machine is. – Dave Long Jun 1 '11 at 17:05
on OSX you can install with brew: brew install ssh-copy-id – phil Nov 21 '13 at 0:26
On Macports, this command can be installed using sudo port install openssh +ssh_copy_id. The +ssh_copy_id installs openssh with the ssh_copy_id variant. – Stefan Lasiewski Sep 18 '14 at 22:23
Note that the instructions on ask you to install untrusted software, as root. This is quite dangerous and a good way to get hacked, unless you know you can trust the author. – Stefan Lasiewski Sep 18 '14 at 22:24

An alternative way to install your public key in the remote machine's authorized_keys:

cat ~/.ssh/ | ssh USER@HOST "mkdir -p ~/.ssh && cat >> ~/.ssh/authorized_keys"

Some advantages:

  • does not require ssh-copy-id to be installed.

  • guarantees that mkdir works before attempting to append to authorized_keys.

share|improve this answer
Your answer helped me to do this on multiple remote machines without any additional packages, thank you. – nol Mar 7 '14 at 10:06
This doesn't guarantee that the "~/.ssh" directory and "~/.ssh/authorized_keys" file will be created with the correct permissions. – Nick Jun 4 '14 at 5:55
@Nick, I had that problem. So then perhaps one must really first check for their existence, if missing create properly with chmod (700/folder, 600/file), and only then add? so then maybe it can't be a one liner? – AnneTheAgile Aug 7 '14 at 3:52
@AnneTheAgile I think changing the mkdir -p ~/.ssh part of the answer given by @MariusButuc to umask 077 && mkdir -p ~/.ssh is all you need to do to ensure that it will work properly. – Nick Aug 7 '14 at 14:02
ty @Nick! I will give it a go. – AnneTheAgile Aug 7 '14 at 21:02
local> scp .ssh/
local> ssh
remote> cat >> .ssh/authorized_keys
remote> rm
remote> exit
share|improve this answer

After saving public key you should save the private key into a directory and file on your pc. And in the auth section of ssh on putty you should point to the private key file that you saved on your desktop. It will work. It works for me.

share|improve this answer
I would just love it if windows console could have all the ssh functionality added into it's interpreter – Dennis Nov 9 '14 at 1:46

Easiest way is to copy and paste...

First view/copy the contents of your local public key including the beginning "ssh-rsa" until it ends with your email address:

cat ~/.ssh/

Then edit authorized_keys on the server and paste contents of your clipboard below any other keys in that file:

nano ~/.ssh/authorized_keys

And save Ctl+O, exit the file Ctl+X, exit the SSH session exit and try logging back in to confirm it worked. If it didn't ask for a password it worked.

share|improve this answer

I thought I can contribute to this since it is about AWS instances specifically and all the answers only treat the problem as a Linux issue, as if it was a piece of hardware. First thing you need to understand is that you should never, ever, don't treat EC2 instances as hardware. That's just going to create more work for you Treat them as volatile. That's the biggest hurdle I see people having with AWS. Make an AMI of your instance and inject the key you need into the new instance. cloud-init will take care of it for you. In more detail all you have to do is use the correct public key when creating the new instance out of the AMI of the original. If, like in the comments of the approved answer you want to generate your own key pair of pub and pem files AWS provides you with the option to upload your public keys for use in EC2.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.