Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I'm running Ubuntu 14.04, Mozilla Firefox 29.0 for Ubuntu Canonical 1.0.

After installation I've watched some YouTube videos and clicked fullscreen, and the popup 'allow full screen?' appeared. By misclick I've clicked 'Don't allow' and 'never ask again'.

Where is this information stored? How can I reverse it? It's very annoying since I can't view embedded YouTube videos in fullscreen until I repair it.

share|improve this question

1 Answer 1

up vote 12 down vote accepted

If you were using YouTube's HTML 5 player (as the "never ask again" in the popup suggests), the fullscreen setting is managed by Firefox (and therefore has nothing to do with Ubuntu or Gnome).

Go to about:permissions (just copy it into your address bar), select from the list and change the setting in the Fullscreen box.

share|improve this answer
Thanks, I'll try it as soon as I get home – fetta May 12 '14 at 8:25
still works, great, thx. – mondjunge Jun 25 at 14:37
I just had this in Firefox 40. I had to restart firefox before youtube was listed in about:permissions. Also fullscreen was still listed as always ask. Selecting "block" and then "always ask" again fixed it. (Perhaps a new bug in 40, it was released this week) – Julian Stirling Aug 17 at 3:36

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.