Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Running Ubuntu 12.04.

I was trying to install something, but I guess I didn't get the dependencies installed. I had a red circle in the top right near the clock, told me to run sudo apt-get or something. When I did, I had some option to remove some stuff and have new stuff installed.

I typed "yes, do as I say!" to confirm, and noticed all my apps on the left side task bar were disappearing. I tried to stop it by holding the power button down. Now when I power up, I can log in, but there's just a desktop, no apps on the left, and no menu (?) bar with the clock and stuff on top. The files and folders on the desktop have no text under them either.

Is there anyway I can repair this? Maybe just reinstall everything?

share|improve this question
    
Installing ubuntu-desktop would be a good start. –  Nattgew May 11 at 4:29

1 Answer 1

Luckily for you, there are apt log files at /var/log/apt/ . The history.log file will contain the last packages which were removed. Look for the last part of the file and try to reinstall the files that were removed or purged.

You need to do a sudo apt-get install <package-names> for all the removed packages. Note that you can specify more that one package name in this command.

share|improve this answer
    
Is there a way to get a terminal open? I tried ctrl+alt+T and nothing happens. And there's no app bar on the left. –  user280328 May 11 at 3:55
    
Yes, you can open a shell by pressing ctrl+alt+F1 and login to the tty1 terminal. To return to normal interface press ctrl+alt+f7 –  Vibhav Sinha May 11 at 3:57
    
Okay. I checked the log, and it looks like it installed a bunch of stuff with i386 after it, and removed tons of stuff for amd64 (which is what I'm on). Do you think I should try to remove the i386 first, or reinstall the amd64 stuff first? Also, when I reinstall the packages, should I type out the whole string eg gnome-media:amd64 (3.4.0-0ubuntu3.1), or just eg gnome-media? –  user280328 May 11 at 4:10
    
Start with installing the required files. The :amd64 suffix is optional and will the ignored but the rest of the version number part (3.4.0-0ubuntu3.1) needs to be removed. –  Vibhav Sinha May 11 at 4:46
    
Thanks so much for the detailed help! I got everything back to exactly how it was. –  user280328 May 11 at 12:35

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.