Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have the following problem: I was trying to upgrade from Ubuntu 13.10 to Ubuntu 14.04 and in the middle (after the necessary packages were downloaded and beginning to be installed), I ran out of space so the whole process froze. After that the only thing I could do was to reboot.

But after the reboot I start getting a:

Kernel panic - not syncing : VFS : Unable to mount the root fs on unknown-block(0,0)
CPU: 0 PID: 1 Comm: swapper/0 Not tainted 3.13.0-24-generic #47-Ubuntu
:
:
and continues with some Call Trace...

I can still enter the grub menu and select between old kernels and in this case it actually boots correctly with Ubuntu 14.04 but then I cannot do anything through the Unity GUI. I can however use a virtual console with Ctrl+Alt+F1 for example...

Anyone had the same problem or knows any way to fix this?

Thanks!

share|improve this question

3 Answers 3

up vote 4 down vote accepted

Maybe something went wrong during update and this will be enough?

Repair after bad update

sudo apt-get update

sudo apt-get -f dist-upgrade

share|improve this answer
    
Thank you very much, you are right. –  Cooli May 11 at 0:08
    
Firstly I thought about compiling new kernel but Unity problems suggested me unfinished installation –  pgr May 11 at 0:09

I ran into a similar problem and here is what I did along with the above steps.

  • Goto recovery/rescue mode from the grub menu, while restarting.
  • Made space available in root partition (alternatively you can extend it if you are using LVM)
  • sudo apt-get update
share|improve this answer

I was able to reboot with previous kernel image. But my mouse was not working. So I switched to console mode and did following sudo apt-get update sudo apt-get -f dist-upgrade

It started working Thanks

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.