Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've got my application up and running, with rails on my ubuntu VPS in Linode with mysql.

here's the version of mysql:

mysql  Ver 14.14 Distrib 5.5.35, for debian-linux-gnu (x86_64) using readline 6.2

It all generally work fine, except that, sometimes when I open a new rails console I get the following error:

/var/www/app/shared/bundle/ruby/2.0.0/gems/mysql2-0.3.14/lib/mysql2/client.rb:67:in `connect': Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2) (Mysql2::Error)
    from /var/www/app/shared/bundle/ruby/2.0.0/gems/mysql2-0.3.14/lib/mysql2/client.rb:67:in `initialize'
    from /var/www/app/shared/bundle/ruby/2.0.0/gems/activerecord-3.2.16/lib/active_record/connection_adapters/mysql2_adapter.rb:16:in `new'
    from /var/www/app/shared/bundle/ruby/2.0.0/gems/activerecord-3.2.16/lib/active_record/connection_adapters/mysql2_adapter.rb:16:in `mysql2_connection'
    from /var/www/app/shared/bundle/ruby/2.0.0/gems/activerecord-3.2.16/lib/active_record/connection_adapters/abstract/connection_pool.rb:315:in `new_connection'
    from /var/www/app/shared/bundle/ruby/2.0.0/gems/activerecord-3.2.16/lib/active_record/connection_adapters/abstract/connection_pool.rb:325:in `checkout_new_connection'
    from /var/www/app/shared/bundle/ruby/2.0.0/gems/activerecord-3.2.16/lib/active_record/connection_adapters/abstract/connection_pool.rb:247:in `block (2 levels) in checkout'
    from /var/www/app/shared/bundle/ruby/2.0.0/gems/activerecord-3.2.16/lib/active_record/connection_adapters/abstract/connection_pool.rb:242:in `loop'
    from /var/www/app/shared/bundle/ruby/2.0.0/gems/activerecord-3.2.16/lib/active_record/connection_adapters/abstract/connection_pool.rb:242:in `block in checkout'
    from /home/user/.rvm/rubies/ruby-2.0.0-p353/lib/ruby/2.0.0/monitor.rb:211:in `mon_synchronize'
    from /var/www/app/shared/bundle/ruby/2.0.0/gems/activerecord-3.2.16/lib/active_record/connection_adapters/abstract/connection_pool.rb:239:in `checkout'
    from /var/www/app/shared/bundle/ruby/2.0.0/gems/activerecord-3.2.16/lib/active_record/connection_adapters/abstract/connection_pool.rb:102:in `block in connection'
    from /home/user/.rvm/rubies/ruby-2.0.0-p353/lib/ruby/2.0.0/monitor.rb:211:in `mon_synchronize'

and from them all attempts to enter the console fail. why the application still works fine and it's still using the database.

If I do in a shell:

$ sudo /etc/init.d/mysql status
 * MySQL is stopped.
$ sudo /etc/init.d/mysql stop
 * Stopping MySQL database server mysqld ... [ OK ] 
$ sudo /etc/init.d/mysql start
 * Starting MySQL database server mysqld ... [fail] 

but the application keeps working fine all the time.

The /var/log/mysql/error.log was empty before these three commands, after them I read:

140510 19:14:32 mysqld_safe Starting mysqld daemon with databases from /var/lib/mysql
140510 19:14:32 [Warning] Using unique option prefix key_buffer instead of key_buffer_size is deprecated and will be removed in a future release. Please use the full name instead.
140510 19:14:32 [Warning] Using unique option prefix myisam-recover instead of myisam-recover-options is deprecated and will be removed in a future release. Please use the full name instead.
140510 19:14:32 [Note] Plugin 'FEDERATED' is disabled.
140510 19:14:32 InnoDB: The InnoDB memory heap is disabled
140510 19:14:32 InnoDB: Mutexes and rw_locks use GCC atomic builtins
140510 19:14:32 InnoDB: Compressed tables use zlib 1.2.8
140510 19:14:32 InnoDB: Using Linux native AIO
140510 19:14:32 InnoDB: Initializing buffer pool, size = 128.0M
140510 19:14:32 InnoDB: Completed initialization of buffer pool
InnoDB: Unable to lock ./ibdata1, error: 11
InnoDB: Check that you do not already have another mysqld process
InnoDB: using the same InnoDB data or log files.
140510 19:14:32  InnoDB: Retrying to lock the first data file
InnoDB: Unable to lock ./ibdata1, error: 11
InnoDB: Check that you do not already have another mysqld process
..... several thousands of these lines... 
InnoDB: Check that you do not already have another mysqld process
InnoDB: using the same InnoDB data or log files.
InnoDB: Unable to lock ./ibdata1, error: 11
InnoDB: Check that you do not already have another mysqld process
InnoDB: using the same InnoDB data or log files.
InnoDB: Unable to lock ./ibdata1, error: 11
InnoDB: Check that you do not already have another mysqld process
InnoDB: using the same InnoDB data or log files.
140510 19:16:12  InnoDB: Unable to open the first data file
InnoDB: Error in opening ./ibdata1
140510 19:16:12  InnoDB: Operating system error number 11 in a file operation.
InnoDB: Error number 11 means 'Resource temporarily unavailable'.
InnoDB: Some operating system error numbers are described at
InnoDB: http://dev.mysql.com/doc/refman/5.5/en/operating-system-error-codes.html
140510 19:16:12 InnoDB: Could not open or create data files.
140510 19:16:12 InnoDB: If you tried to add new data files, and it failed here,
140510 19:16:12 InnoDB: you should now edit innodb_data_file_path in my.cnf back
140510 19:16:12 InnoDB: to what it was, and remove the new ibdata files InnoDB created
140510 19:16:12 InnoDB: in this failed attempt. InnoDB only wrote those files full of
140510 19:16:12 InnoDB: zeros, but did not yet use them in any way. But be careful: do not
140510 19:16:12 InnoDB: remove old data files which contain your precious data!
140510 19:16:12 [ERROR] Plugin 'InnoDB' init function returned error.
140510 19:16:12 [ERROR] Plugin 'InnoDB' registration as a STORAGE ENGINE failed.
140510 19:16:12 [ERROR] Unknown/unsupported storage engine: InnoDB
140510 19:16:12 [ERROR] Aborting

140510 19:16:12 [Note] /usr/sbin/mysqld: Shutdown complete

140510 19:16:12 mysqld_safe mysqld from pid file /var/run/mysqld/mysqld.pid ended

Only rebooting the VPS seems to solve the issue, which comes back after one or two console connections.

I figured that shutting down Mysql from init.d doesn't shut it down, to stop it I need to kill it, then it automatically respawns.

$ ps -ef | grep mysq[l]
mysql    31063     1  0 May19 ?        00:00:34 /usr/sbin/mysqld
$ sudo /etc/init.d/mysql stop
 * Stopping MySQL database server mysqld                                 [ OK ] 
$ ps -ef | grep mysq[l]
mysql    31063     1  0 May19 ?        00:00:34 /usr/sbin/mysqld
$ sudo kill -9 31063
$ ps -ef | grep mysq[l]
mysql     6052     1  3 09:23 ?        00:00:00 /usr/sbin/mysqld
$ 

any clue?

share|improve this question

1 Answer 1

This might be because mysql could not start whiling booting up.

Try this remedy

/etc/init.d/mysqld restart

or try this

Remove basedir attribute from /etc/my.cnf file

Why?

The basedir directive instructs MySQL where to find everything it needs to function: binaries, libraries, data, etc. Hence by stipulatingbasedir=/var/lib, MySQL will search /var/lib for everything needed to perform its functions.

For typical installs via RPM, this directive is not needed and should not be used. For a more exhaustive description of this directive, please consult the MySQL manual.

note

I infact once faced this issue due to memory issue as well. Try and check for free memory as well.

Reference URL

http://www.tech-recipes.com/rx/762/solve-cant-connect-to-local-mysql-server-through-socket-tmpmysqlsock/

share|improve this answer
    
/etc/init.d/mysqld restart I tried too, and it doesn't improve the situation. –  user72464 May 10 at 19:55
    
Sorry I just figured that there was a "part two" in your answer, I've tried commenting out the basedir attribute in the /etc/mysql/my.cnf file, and then restarting mysql, I still got a fail. any more ideas? –  user72464 May 13 at 22:32
    
Check out the link i just posted –  cafebabe1991 May 15 at 16:02
    
Thank you I'll try that asap –  user72464 May 20 at 9:26

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.