Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

apt-get stopped working for me. It resolves us.archive.ubuntu.com to an IP address, but then does not connect to that address. I can ping that IP address and can also do a wget on the IP address and successfully download the page. I am connecting through a proxy, which is working fine for everything. apt-get has worked before, but stopped recently (I'm not the only one that uses the box, so not sure what could have changed).

Any ideas?

Thanks.

share|improve this question

closed as too localized by jrg Feb 28 '12 at 13:17

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
About what time period are we talking? I see timeouts every now and then but such phases don't last long (couple of minutes tops). Have you tried different mirrors (gksu software-properties-gtkDownload from:)? –  htorque Jun 1 '11 at 13:26
    
Do other mirrors work? Does the problem persist over a long period of time (several days)? –  Gilles Jun 1 '11 at 21:05
    
This question appears to be abandoned, if you are experiencing a similar issue please ask a new question with details pertaining to your problem. If you feel this question is not abandoned, please flag the question explaining that. :) –  Ringtail Feb 28 '12 at 0:30

1 Answer 1

I have solved a similar problem editing /etc/apt/apt.conf (if not exist, you can create it)

adding, with sudo,

Acquire::http::Proxy "http://username:password@proxyip:proxyport/";

quotes and semicolon included.

I'm on Lucid.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.