Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I Have these config: 1) maas on VM 2) 3 ready node in VM 3) when i try to juju bootstrap -- debug I see this error

It tries to connect https://streams.canonical.com/juju/tools/streams/v1/index.json and it returns :

dial tcp 91:189:88.141:443 : connection refused!

share|improve this question
    
What OS are these machines being virtualized on? What virtualization software? What networking settings do you have set for the Virualization software? What address ranges is MAAS set to give out? What machine is MAAS running on (on of the VMs?). Is MAAS set to "Manage DHCP" or "Manage DHCP & DNS" or "Unmanaged" for the network? Can the Juju client (machine you are interacting with Juju on) get to the internet? Is the machine you are using Juju from a VM or some other computer? If you could edit your question with these details, it would help. –  Azendale May 10 at 0:51
    
Can the Juju client (machine you are interacting with Juju on) get to the internet? I did test both case juju in another VM 1) in my main Server (connected to internet and the VMM istalled on it) i got 502:bad gateway ( after juju bootstrap) and in the vm i got above mentioned error! and Is the machine you are using Juju from a VM or some other computer? not from another computer i used vm on same computer If you could edit your question with these details, it would help. –  Rastin May 12 at 20:23
    
What OS are these machines being virtualized on? Ubuntu 14.04 What virtualization software? VMM What networking settings do you have set for the Virualization software? new Network setupped in VMM ( NAT) What address ranges is MAAS set to give out? 192.168.120.100 192.168.120.200 What machine is MAAS running on (on of the VMs?) yes on VM . Is MAAS set to "Manage DHCP" or "Manage DHCP & DNS" or "Unmanaged" for the network? manage DHCP and DNS –  Rastin May 12 at 20:25
    
My connection to internet is through proxy! –  Rastin May 12 at 20:50
    
The best way to add additional information to your question is by editing it, with the edit button. It is better visible that way, and comments are mainly for secondary, temporary purposes. Comments are removed under a variety of circumstances. Anything important to your question should be in the question itself. –  guntbert May 15 at 18:07

1 Answer 1

up vote 0 down vote accepted


I found the problem's solution. it will be show up in cases you have proxy!

just define no_proxy="...." in /etc/environment for both m server and juju client.
and define no-proxy="..." in ~/.juju/environment.yaml
Hope this save a lot of time for you

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.