Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have two internal hard drives; 1 for Windows 8.1 and 1 for storage. I decided to install Ubuntu on the secondary hard drive. One of the guides I used advised me to make a small boot partition in the free space as well, so I did. After my installation my computer defaults to the Ubuntu partition and I cannot boot to Windows 8.1.

This is the error Windows gives me:

Windows Boot Manager:

File: \Boot\BGD (It may be BCD [The picture I took with my phone is blurry])
Status: 0xc000000f
Info: The Book Configuration Data for your PC is missing or contains errors.

What I've tried: - First, yes I have been Googling for an hour now - I tried to boot from my Windows hard drive thinking that since I selected a bootloader on the secondary hard drive during installation. - The message also recommended I insert my installation disk and "repair my computer" I ran the programs and no luck.

Please, does anyone know how I could restore my Windows partition? (At least have me get in so I can run EasyBCD.)

EDIT: I have just installed Grub-Customizer and the only options available to me are for Ubuntu. Could this possibly be because the Windows Bootloader is on the other hard driver? GParted shows that it is still there.

share|improve this question

1 Answer 1

up vote 1 down vote accepted

How far can you get into your recovery disc? If you can enter CMD, you can follow this guide. This will reinstall the Windows 8 boot loader onto your primary hard drive's MBR.

Usually I'd include the steps upon posting, but the post is too long. Let me know how you get on, or how far you get, and if a success, I will rewrite the instructions into this post.

share|improve this answer
    
This seems to be the solution, however, I made it down the guide until I got to cd /d the folder was not found. I have selected previously the volume that was 300MB and labeled system. Another thing I should mention is that in the guide, it says all file systems should be fat32. For some reason both hard drives of mine are NTFS. Don't know if that makes a different or not. –  Stephen May 9 at 20:59
    
No, the guide says that the EFI partition should be FAT32. Not all file systems. Also, the /d should be a /D, though it should work lower/uppercase (I think) as the /D switch is to change the working drive in addition to changing the working directory. –  adampski May 9 at 21:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.