Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

In Unity, when I make a mobile broadband connection, I can dial-up in the bluetooth manager, saying my connection will appear in the Network manager, but it doesn't. Any ideas?

share|improve this question

A couple of things may be wrong here:

  1. You need to make absolutely sure you've selected the 3G provider (and plan if applicable) for what you're using for your mobile broadband.

  2. You need to make sure that the device (your 3G-dongle (or 4G if that's what you're using)) is mounted and receiving signal. On the common Huawei 3G modems, this is indicated by the green light on the top of the modem switching to a blinking blue when receiving signal and a solid blue when connected.

  3. On some Huawei modems (there may be other brands I don't know of that have this problem as well) the hardware is not natively supported, and since its driver relies on authentication through a windows only program, the way I have solved this is by connecting my modem to a windows machine for the first run, from which I disabled PIN-authentication on the modem. That solved my issues with connecting via Network Manager.

If none of the above seems to be the issue, another explanation could be that your modem has not been properly removed and that something is corrupted.

share|improve this answer

I have a mobile broadband connection with USB modem. When I set it up, it worked right away, but when I loose connection, in order to reconnect I must put USB modem out and plug it in again, then unmount it, and reconnect.

I know this is not an answer, but that's all I can say about my expirience with mobile broadband connection.

share|improve this answer
Yes, although I always connect through a bluetooth connection, that also used to happen in previous Ubuntu versions, but that's not a big problem actually. It's that now the initial setup isn't possible. – Dries Jun 1 '11 at 8:03
So, you were able to do initial setup successfully on previous versions of Ubuntu. But after update to 11.04 it fails, right? – umpirsky Jun 1 '11 at 8:20
Yes, the "mobile broadband section" just doesn't appear anymore to connect in the network manager – Dries Jun 1 '11 at 13:53
I suggest you to post a bug. It worked before. – umpirsky Jun 1 '11 at 14:06

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.